Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 870457 - net-misc/unix2tcp-0.8.2-r1:0 - configure:656:1: error: return type defaults to 'int' [-Werror=implicit-int]
Summary: net-misc/unix2tcp-0.8.2-r1:0 - configure:656:1: error: return type defaults t...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 871276 (view as bug list)
Depends on:
Blocks: clang-16-porting
  Show dependency tree
 
Reported: 2022-09-16 19:08 UTC by Toralf Förster
Modified: 2022-09-28 02:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,19.38 KB, text/plain)
2022-09-16 19:08 UTC, Toralf Förster
Details
emerge-history.txt.bz2 (emerge-history.txt.bz2,68.28 KB, application/x-bzip)
2022-09-16 19:08 UTC, Toralf Förster
Details
environment (environment,22.95 KB, text/plain)
2022-09-16 19:08 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,26.87 KB, application/x-bzip)
2022-09-16 19:08 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,669 bytes, application/x-bzip)
2022-09-16 19:08 UTC, Toralf Förster
Details
net-misc:unix2tcp-0.8.2-r1:20220916-180857.log (net-misc:unix2tcp-0.8.2-r1:20220916-180857.log,2.57 KB, text/plain)
2022-09-16 19:08 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,8.56 KB, application/x-bzip)
2022-09-16 19:08 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-09-16 19:08:30 UTC
./configure --prefix=/usr --build=x86_64-pc-linux-gnu --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --libdir=/usr/lib64
creating cache ./config.cache
checking for gcc... gcc
checking whether the C compiler (gcc -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0) works... no
configure: error: installation or configuration problem: C compiler cannot create executables.

!!! Please attach the following file when seeking support:

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-j4-20220913-110042

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-9.3.1
 [2] x86_64-pc-linux-gnu-12.2.1 *
clang/llvm (if any):
Python 3.10.7
Available Ruby profiles:
  [1]   ruby27 (with Rubygems)
  [2]   ruby31 (with Rubygems) *
Available Rust versions:
  [1]   rust-bin-1.63.0 *
The following VMs are available for generation-2:
1)	Eclipse Temurin JDK 11.0.16.1_p1 [openjdk-bin-11]
2)	Eclipse Temurin JDK 17.0.4.1_p1 [openjdk-bin-17]
*)	Eclipse Temurin JDK 8.345_p01 [openjdk-bin-8]
4)	Eclipse Temurin JRE 17.0.4.1_p1 [openjdk-jre-bin-17]
Available Java Virtual Machines:
  [1]   openjdk-bin-8  system-vm
  [2]   openjdk-bin-11 
  [3]   openjdk-bin-17 
  [4]   openjdk-jre-bin-17 

The Glorious Glasgow Haskell Compilation System, version 9.0.2
php cli (if any):
GNU Make 4.3.90

  HEAD of ::gentoo
commit e5cd60aa15289f27c42e8230065d3f4c599234a6
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Fri Sep 16 17:46:46 2022 +0000

    2022-09-16 17:46:45 UTC

emerge -qpvO net-misc/unix2tcp
[ebuild  N    ] net-misc/unix2tcp-0.8.2-r1
Comment 1 Toralf Förster gentoo-dev 2022-09-16 19:08:31 UTC
Created attachment 805951 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2022-09-16 19:08:32 UTC
Created attachment 805954 [details]
emerge-history.txt.bz2
Comment 3 Toralf Förster gentoo-dev 2022-09-16 19:08:33 UTC
Created attachment 805957 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2022-09-16 19:08:36 UTC
Created attachment 805960 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2022-09-16 19:08:37 UTC
Created attachment 805963 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2022-09-16 19:08:38 UTC
Created attachment 805966 [details]
net-misc:unix2tcp-0.8.2-r1:20220916-180857.log
Comment 7 Toralf Förster gentoo-dev 2022-09-16 19:08:39 UTC
Created attachment 805969 [details]
temp.tar.bz2
Comment 8 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-09-17 00:14:43 UTC
configure:530: checking for gcc
configure:643: checking whether the C compiler (gcc -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0) works
configure:659: gcc -o conftest -pipe -march=native -fno-diagnostics-color -O2 -D_GLIBCXX_ASSERTIONS -Werror=implicit-function-declaration -Werror=implicit-int  -Wl,-O1 -Wl,--as-needed -Wl,--defsym=__gentoo_check_ldflags__=0 conftest.c  1>&5
configure:656:1: error: return type defaults to 'int' [-Werror=implicit-int]
  656 | main(){return(0);}
      | ^~~~
cc1: some warnings being treated as errors
configure: failed program was:

#line 654 "configure"
#include "confdefs.h"

Legit.
Comment 9 Larry the Git Cow gentoo-dev 2022-09-28 02:35:23 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=f1a5c3617bbcc1b80db4f14b8e2a189c6ac9170e

commit f1a5c3617bbcc1b80db4f14b8e2a189c6ac9170e
Author:     Ionen Wolkens <ionen@gentoo.org>
AuthorDate: 2022-09-28 00:52:25 +0000
Commit:     Ionen Wolkens <ionen@gentoo.org>
CommitDate: 2022-09-28 02:34:35 +0000

    net-misc/unix2tcp: fix build with clang16
    
    Both run eautoreconf and add missing includes for
    implicit declaration issues beyond it.
    
    Closes: https://bugs.gentoo.org/870457
    Signed-off-by: Ionen Wolkens <ionen@gentoo.org>

 net-misc/unix2tcp/files/unix2tcp-0.8.2-clang16.patch | 19 +++++++++++++++++++
 net-misc/unix2tcp/unix2tcp-0.8.2-r1.ebuild           | 12 ++++++++++++
 2 files changed, 31 insertions(+)
Comment 10 Ionen Wolkens gentoo-dev 2022-09-28 02:42:42 UTC
*** Bug 871276 has been marked as a duplicate of this bug. ***