Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 870373 - app-portage/gentoolkit-0.5.1-r1: equery completion confused by .conf~ files with tilde
Summary: app-portage/gentoolkit-0.5.1-r1: equery completion confused by .conf~ files w...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-09-16 14:23 UTC by m1027
Modified: 2022-09-18 08:07 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description m1027 2022-09-16 14:23:21 UTC
Hi,

some gentoo tools seem to create backups of conf files below /etc/portage by adding a tilde. I don't care (here) where these come from. It's not from my editor. Maybe from flaggie or crossdev or equery repository.

The issue: equery tab completion seems to read these disabled files. In turn it complains when these files point to invalid data. Is it correct that equery reads such backup config files with tilde at all?

For example:

- I had /etc/portage/repos.conf/eselect-repo.conf~ pointing to (non existent) /var/db/repos/wayland-desktop.
- equery <TAB>

Output:
- garbled console, then
- bash: cd: /var/db/repos/wayland-desktop: No such file or directory

Obvious fix:

- Remove the invalid conf + tile file.


Thanks