Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 86907 - "gst-launch-0.8 sinesrc ! alsasink" fails, ".... ! osssink" works (using alsa)
Summary: "gst-launch-0.8 sinesrc ! alsasink" fails, ".... ! osssink" works (using alsa)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: GStreamer package maintainers
Depends on:
Reported: 2005-03-27 16:19 UTC by Carl Jackson
Modified: 2006-03-27 06:18 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

gst.log.bz2 output referred to above (gst.log.bz2,18.19 KB, text/plain)
2005-03-27 16:22 UTC, Carl Jackson
gst.log.bz2 output referred to above, this time posted as binary (gst.log.bz2,18.19 KB, application/octet-stream)
2005-03-27 16:24 UTC, Carl Jackson
gst.log.bz2 output after updating packages (gst.log.bz2,18.04 KB, application/octet-stream)
2005-03-27 17:32 UTC, Carl Jackson

Note You need to log in before you can comment on or make changes to this bug.
Description Carl Jackson 2005-03-27 16:19:20 UTC
First bug report.  We'll see how this goes, I apologize in advance for any ingoramus mistakes...

Using the Epox 8KDA3+ (amd64) onboard nforce3 (intel8x0) sound chip. 

some commands with output:

> gst-launch-0.8 sinesrc ! alsasink
RUNNING pipeline ...
ERROR: pipeline doesn't want to play.

the above gives no sound output.

> gst-launch-0.8 sinesrc ! osssink
RUNNING pipeline ...

the above plays the sine wave.

Using most recent available ebuilds of gstreamer (0.8.8), gst-plugins (0.8.7), & alsa-lib (1.0.8).

Tried manually compiling gstreamer 0.8.9 and gst-plugins 0.8.8 with some success (i.e. got sound from osssink), but had same symptoms as above with alsasink as well as some other issues, so I reverted back to ebuilds.  Hopefully enough information is contained in attached gst.log.bz2 file to troubleshoot.
Comment 1 Carl Jackson 2005-03-27 16:22:18 UTC
Created attachment 54629 [details]
gst.log.bz2 output referred to above

output of:

gst-launch-0.8 --gst-debug-level=5 sinesrc ! alsasink &> gst.log
Comment 2 Zaheer Abbas Merali (RETIRED) gentoo-dev 2005-03-27 16:24:24 UTC
There are ebuilds for gstreamer 0.8.9 and gst-plugins-0.8.8

Just unmask them in /etc/portage/package.keywords

I will look at the log tomorrow.
Comment 3 Carl Jackson 2005-03-27 16:24:54 UTC
Created attachment 54630 [details]
gst.log.bz2 output referred to above, this time posted as binary

output of:

gst-launch-0.8 --gst-debug-level=5 sinesrc ! alsasink &> gst.log

This time posted (hopefully correctly) as binary instead of text.
Comment 4 Carl Jackson 2005-03-27 17:32:26 UTC
Created attachment 54635 [details]
gst.log.bz2 output after updating packages

Thanks for the tip, got the packages updated to the current releases (gstreamer
0.8.9, gst-plugins 0.8.8).

Here's the new gst.log after the updates.
Comment 5 Carl Jackson 2005-03-27 18:26:52 UTC
Ok.  Been fooling around some more with the system, and have managed to get some sound out of it.  Upgraded gst-plugins-faad to 0.8.8 in between last post and this, for what its worth.

New command:

gst-launch-0.8 sinesrc ! alsasink device="plug:dmix"

Issue now is that sound is choppy (plays for a few seconds, stops/starts, repeats).  Same with other sound files I've tried (flac, mp3), up to point where some (mp3) will completely stall after <0.5 seconds.  Will continue experimenting.  Let me know if there's any additional debug output that would be useful (and how to get it). Incidentally, using osssink still seems to provide ok output.
Comment 6 Zaheer Abbas Merali (RETIRED) gentoo-dev 2005-04-11 07:55:22 UTC
do u get choppy playback using dmix in mplayer or other audio players?
Comment 7 Zaheer Abbas Merali (RETIRED) gentoo-dev 2005-07-13 05:19:45 UTC
do you still have this issue? (with latest gst-plugins 0.8.10 and alsa 1.0.9 and
kernel 2.6.12)
Comment 8 Zaheer Abbas Merali (RETIRED) gentoo-dev 2006-03-27 05:47:13 UTC
ping!!! its been nearly a year :)
Comment 9 foser (RETIRED) gentoo-dev 2006-03-27 06:18:31 UTC
resolving for reason stated above