Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 866001 - app-text/evince-43.1-r1 installs files into unexpected paths
Summary: app-text/evince-43.1-r1 installs files into unexpected paths
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 901117 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-08-22 07:47 UTC by Agostino Sarubbo
Modified: 2024-07-15 20:18 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,889.76 KB, text/plain)
2022-08-22 07:47 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2022-08-22 07:47:24 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-text/evince-42.3 installs files into unexpected paths.
Discovered on: amd64 (internal ref: lto_tinderbox)

NOTE:
This machine uses lto with CFLAGS=-flto -Werror=odr -Werror=lto-type-mismatch -Werror=strict-aliasing

Here is a bit of explanation:

-Werror=lto-type-mismatch:
User to find possible runtime issues in packages. It likely means the package is unsafe to build & use with LTO.
For projects using the same identifier but with different types across different files, they must be fixed to be consistent across the codebase.

-Werror=odr:
Used to find possible runtime issues in packages. These bugs are a problem anyway but may be even worse when combined with LTO. C++ code must comply with the One Definition Rule (ODR) - see https://en.cppreference.com/w/cpp/language/definition#One_Definition_Rule.

-Werror=strict-aliasing:
Used to find possible runtime issues in packages. These bugs are a problem anyway but may be even worse when combined with LTO.

Workarounds:
- If upstream is friendly and still active, file a bug upstream. For emulators, codecs, games, or multimedia packages, it may be worth just applying a workaround instead, as upstreams sometimes aren't receptive to these bugs (VALID FOR ALL).
- Use the new 'filter-lto' from flag-o-matic.eclass as it's likely to be unsafe with LTO (VALID FOR lto-type-mismatch - odr).
- Fix it yourself if interested, of course (VALID FOR ALL).
- Append-flags -fno-strict-aliasing (VALID FOR strict-aliasing).
- Use memcpy() but a union is sometimes suitable too (VALID FOR strict-aliasing).
- -fstrict-aliasing is implied by -O2, so this must be addressed in some form (VALID FOR strict-aliasing).

See also: https://marc.info/?l=gentoo-dev&m=165639574126280&w=2
Comment 1 Agostino Sarubbo gentoo-dev 2022-08-22 07:47:26 UTC
Created attachment 800407 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2022-09-22 07:31:44 UTC
ci has reproduced this issue with version 43.0 - Updating summary.
Comment 3 Agostino Sarubbo gentoo-dev 2022-10-29 20:00:41 UTC
ci has reproduced this issue with version 43.1 - Updating summary.
Comment 4 Agostino Sarubbo gentoo-dev 2022-12-16 08:09:36 UTC
ci has reproduced this issue with version 43.1-r1 - Updating summary.
Comment 5 Larry the Git Cow gentoo-dev 2023-03-13 17:33:08 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=2c3e3ff9a84d714178483d595436ab8a6e1e6c5a

commit 2c3e3ff9a84d714178483d595436ab8a6e1e6c5a
Author:     Guillermo Joandet <gjoandet@gmail.com>
AuthorDate: 2023-03-12 04:20:56 +0000
Commit:     Matt Turner <mattst88@gentoo.org>
CommitDate: 2023-03-13 17:33:02 +0000

    app-text/evince: Version bump to 44_rc
    
    Closes: https://bugs.gentoo.org/866001
    Closes: https://github.com/gentoo/gentoo/pull/30072
    Signed-off-by: Guillermo Joandet <gjoandet@gmail.com>
    Signed-off-by: Matt Turner <mattst88@gentoo.org>

 app-text/evince/Manifest            |   1 +
 app-text/evince/evince-44_rc.ebuild | 137 ++++++++++++++++++++++++++++++++++++
 profiles/package.mask               |   1 +
 3 files changed, 139 insertions(+)
Comment 6 Matt Turner gentoo-dev 2023-03-14 12:39:33 UTC
*** Bug 901117 has been marked as a duplicate of this bug. ***
Comment 7 Agostino Sarubbo gentoo-dev 2023-03-14 12:49:01 UTC
reopening to avoid duplicate until it's at least in ~arch