Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 86137 - xorg-x11 states "Previous xorg-x11 installation detected" during emerge, even on a new install
Summary: xorg-x11 states "Previous xorg-x11 installation detected" during emerge, even...
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-21 07:47 UTC by MAL
Modified: 2006-03-31 20:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MAL 2005-03-21 07:47:10 UTC
Summary says it all really...

# emerge -pv xorg-x11

[ebuild  N    ] x11-base/xorg-x11-6.8.2-r1  -3dfx -3dnow +bitmap-fonts -cjk -debug -dlloader -dmx -doc -font-server -hardened +insecure-drivers -ipv6 -minimal +mmx -nls +opengl +pam -sdk +sse -static +truetype-fonts +type1-fonts (-uclibc) -xprint +xv 0 kB

# emerge xorg-x11

Calculating dependencies ...done!
>>> emerge (1 of 4) x11-base/xorg-x11-6.8.2-r1 to /
>>> md5 src_uri ;-) eurofonts-X11.tar.bz2
>>> md5 src_uri ;-) gentoo-cursors-tad-0.3.1.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-files-0.1.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-patches-0.1.2.tar.bz2
>>> md5 src_uri ;-) X11R6.8.2-src.tar.bz2
 
 * Previous xorg-x11 installation detected
 * Enabling PAM features in xorg-x11...
>>> Unpacking source...
 * Unpacking 6.8.2 source...

With the important line being "Previous xorg-x11 installation detected".  Should that be better worded, or is it a bug?

Reproducible: Always
Steps to Reproduce:




Portage 2.0.51.19 (default-linux/x86/2004.3, gcc-3.2.3, glibc-2.3.2-r3, 2.4.29 i686)
=================================================================
System uname: 2.4.29-rigel i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.2.3-r5,dev-lang/python-2.3.4-r1 [2.3.4
(#1, Mar 18 2005, 05:46:39)]
dev-lang/python:     2.2.3-r5, 2.3.4-r1
sys-devel/autoconf:  2.59-r5
sys-devel/automake:  1.8.5-r1
sys-devel/binutils:  2.15.90.0.1.1-r3
sys-devel/libtool:   1.4.3-r1, 1.5.2-r7
virtual/os-headers:  2.4.19-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks notitles sandbox sfperms"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
USE="x86 apache2 apm berkdb bitmap-fonts crypt cups directfb dvd dvdr dvdread
edl emboss encode fbcon foomaticdb fortran freetype gdbm gif gpm imagemagick
imlib insecure-drivers jpeg libg++ libwww mikmod mmx mmx2 motif mp3 mpeg ncurses
oggvorbis opengl oss pam pdflib perl png python qt readline rtc slang spell sse
sse2 ssl tcpd tiff truetype truetype-fonts type1-fonts xml2 xv zlib
video_cards_savage"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Donnie Berkholz (RETIRED) gentoo-dev 2005-03-21 10:45:31 UTC
Run `equery list xorg-x11` -- equery's part of gentoolkit.
Comment 2 Priit Laes (IRC: plaes) 2005-04-19 01:09:45 UTC
I also noticed this behavior on stage1 install. I certainly didn't have xorg-x11 installed.
Comment 3 Joshua Baergen (RETIRED) gentoo-dev 2005-04-24 21:42:51 UTC
It's been a month since new information was requested; please re-open when you respond to Donnie's request :)
Comment 4 MAL 2005-04-25 04:44:06 UTC
Sorry, the update must have bounced from my mailbox.

Run equery on what?  The machine with the problem now has xorg installed.
Comment 5 Ruslan N. Marchenko 2005-05-21 07:13:07 UTC
hm. i have the same with xorg-x11-6.8.2-r1

relay Oracle10g # equery list xorg-x11
[ Searching for package 'xorg-x11' in all categories among: ]
 * installed packages

>>> emerge (1 of 5) x11-base/xorg-x11-6.8.2-r1 to /
>>> md5 files   ;-) xorg-x11-6.8.2-r1.ebuild
>>> md5 files   ;-) xorg-x11-6.8.99.3.ebuild
>>> md5 files   ;-) xorg-x11-6.8.99.5.ebuild
>>> md5 files   ;-) xorg-x11-6.8.2-r2.ebuild
>>> md5 files   ;-) ChangeLog
>>> md5 files   ;-) metadata.xml
>>> md5 files   ;-) files/digest-xorg-x11-6.8.2-r1
>>> md5 files   ;-) files/digest-xorg-x11-6.8.2-r2
>>> md5 files   ;-) files/digest-xorg-x11-6.8.99.3
>>> md5 files   ;-) files/digest-xorg-x11-6.8.99.5
>>> md5 src_uri ;-) eurofonts-X11.tar.bz2
>>> md5 src_uri ;-) gentoo-cursors-tad-0.3.1.tar.bz2
>>> md5 src_uri ;-) gemini-koi8-u.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-files-0.1.tar.bz2
>>> md5 src_uri ;-) xorg-x11-6.8.2-patches-0.1.2.tar.bz2
>>> md5 src_uri ;-) X11R6.8.2-src.tar.bz2

 * Previous xorg-x11 installation detected
 * Enabling PAM features in xorg-x11...
>>> Unpacking source...


Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.3.5-20050130,
glibc-2.3.4.20041102-r1, 2.6.11.9 i686)
=================================================================
System uname: 2.6.11.9 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, May 17 2005, 10:52:06)]
dev-lang/python:     2.3.5
sys-apps/sandbox:    [Not Present]
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.5, 1.8.5-r3, 1.7.9-r1, 1.6.3, 1.4_p6, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.16
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -fomit-frame-pointer -pipe -march=pentium4"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -fomit-frame-pointer -pipe -march=pentium4"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://mirror.aiya.ru/pub/gentoo/
ftp://mirror.aiya.ru/pub/gentoo/ http://src.gentoo.pl
http://mirror.switch.ch/mirror/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 acpi apache2 apm arts berkdb bitmap-fonts crypt curl emboss encode
foomaticdb freedts gdbm gif gpm imlib ipv6 jpeg libg++ libwww ncurses nls nptl
odbc pam pdflib perl png readline samba spell sse ssl tcpd truetype
truetype-fonts type1-fonts xml2 zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTDIR_OVERLAY

and xorg doesn't compiles at all
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/include'
including in ./config...
make[2]: Entering directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config'
make[2]: *** No rule to make target `includes'.  Stop.
make[2]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc/config'
make[1]: *** [includes] Error 2
make[1]: Leaving directory `/var/tmp/portage/xorg-x11-6.8.2-r1/work/xc'
make: *** [World] Error 2

!!! ERROR: x11-base/xorg-x11-6.8.2-r1 failed.
!!! Function build, Line 954, Exitcode 2
!!! make World failed
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2006-03-31 20:09:19 UTC
Won't be fixed, please give modular X a try.