Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 86023 - libusb fails to configure on PPC Linux
Summary: libusb fails to configure on PPC Linux
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Alastair Tse (RETIRED)
Depends on:
Reported: 2005-03-20 09:11 UTC by Nick Lassonde
Modified: 2005-05-11 00:36 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Nick Lassonde 2005-03-20 09:11:35 UTC
Emerging libusb-0.1.10a results in:

>>> Unpacking libusb-0.1.10a.tar.gz to /var/tmp/portage/libusb-0.1.10a/work
aclocal-1.9: `' or `' is required

Looking at the ebuild, I see some special casing is done for macos, and that it is also done for generic PPC...

So, I changed line 23 from:
	if use ppc || use ppc-macos ; then
	if use ppc-macos ; then

I don't know if this is the correct fix, but it did allow me to emerge successfuly.

Reproducible: Always
Steps to Reproduce:
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2005-03-21 06:21:49 UTC
can ppc guys confirm this?
Comment 2 Lars Weiler (RETIRED) gentoo-dev 2005-03-21 07:07:33 UTC
Yes, I can confirm this error.  And I can also confirm the fix.
Comment 3 Jouni Rinne 2005-03-21 09:03:57 UTC
The same here (on Gentoo-PPC): same error, and the fix worked
Comment 4 Wouter Depuydt 2005-03-23 05:24:17 UTC
I also can confirm this error, and the proposed fix solves it.
Running gentoo-ppc 2004.3 on a Powerbook DVI 667MHz.
Comment 5 Alastair Tse (RETIRED) gentoo-dev 2005-03-23 06:08:30 UTC
thanks, sorry for the delay as i was away from my dev machine for acouple of days.
Comment 6 Nick Lassonde 2005-05-11 00:36:15 UTC
Forgot to mark closed. Thanks.