Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 85937 - emerge auto-skip failed ebuilds
Summary: emerge auto-skip failed ebuilds
Status: RESOLVED DUPLICATE of bug 12768
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Ebuild Support (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-19 13:07 UTC by Daevid Vincent
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daevid Vincent 2005-03-19 13:07:04 UTC
I would like to submit a feature request to whomever manages 'portage' and specifically 'emerge'.

It seems that when I do an 'emerge -Davu world', sometimes there are > 30 packages, I've seen even as many as a > 100. There's nothing more frustrating than finally getting through all the BS of editing /etc/portage/package.keywords and finally getting the packages to start building to find out the next day (because you HAVE to leave it running during the night) that package #2 shit the bed.

WTF isn't 'emerge' smart enough to just gracefully move on to the next package and keep doing so until the end of the list. Not EVERY package requires EVERY other package. This isn't an all or nothing scenario. Surely some packages could have been compiled and merged in spite of previous failed packages.
Comment 1 Alec Warner archtester gentoo-dev Security 2005-03-19 13:51:08 UTC
Dupe of 12768 perhaps?  There are actually alot of bugs that detail similar behavior requests.

portage isn't 'smart' enough to do what you describe because packages aren't in a big straight list that portage can just shoot through.  You have to have depgraphs for everything, which means you have to find the next package that doesn't depend on anything that failed...which is hard.  This behavior is being worked on and I think will be in the portage with the new resolver.
Comment 2 SpanKY gentoo-dev 2005-03-19 13:55:52 UTC
hrm, thought i already duped it ... must have closed all my windows by accident

*** This bug has been marked as a duplicate of 12768 ***