Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 85626 - kdelibs-3.4.0 has useless DEPEND on cyrus-sasl ?
Summary: kdelibs-3.4.0 has useless DEPEND on cyrus-sasl ?
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-17 05:59 UTC by SpanKY
Modified: 2005-03-17 13:32 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description SpanKY gentoo-dev 2005-03-17 05:59:19 UTC
went to upgrade my KDE today and found that kdelibs wanted cyrus-sasl ?

no idea what this pkg is for and i didnt need it with kde-3.3.x, so i just injected it and tried emerging my packages ... they built fine

perhaps kdelibs should have DEPEND="sasl? ( cyrus-sasl )" ?
Comment 1 Simone Gotti (RETIRED) gentoo-dev 2005-03-17 06:16:22 UTC
This was already addressed in other bugs (for example #78290). 
We added that flag the first time, but without cyrus sasl we lost some important features and we get a lot of users complaining this without knowing that this was provided by cyrus sasl. So we decided to make it a fixed dep.

Comment 2 SpanKY gentoo-dev 2005-03-17 06:36:44 UTC
not to annoy, but to reinforce ...
Comment 3 SpanKY gentoo-dev 2005-03-17 06:37:25 UTC
... the fact that this is a WONTFIX bug not an INVALID one

ignorant users does not make something like this INVALID
Comment 4 Simone Gotti (RETIRED) gentoo-dev 2005-03-17 13:32:06 UTC
Sorry. I was sure that I choosed WONTFIX :P