Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 853949 - media-gfx/prusaslicer-2.4.2: compilation fails ‘ofstream’ is not a member of ‘boost::filesystem’
Summary: media-gfx/prusaslicer-2.4.2: compilation fails ‘ofstream’ is not a member of ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: 3D Printing Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: boost-1.79
  Show dependency tree
 
Reported: 2022-06-23 20:57 UTC by xiaojie+bugzillagentoo
Modified: 2022-06-24 07:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,56.43 KB, text/x-log)
2022-06-23 20:58 UTC, xiaojie+bugzillagentoo
Details
emerge --info (info.log,6.13 KB, text/x-log)
2022-06-23 20:59 UTC, xiaojie+bugzillagentoo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xiaojie+bugzillagentoo 2022-06-23 20:57:11 UTC
Trying to compile prusaslicer-2.4.2, fails on 
/var/tmp/portage/media-gfx/prusaslicer-2.4.2/work/PrusaSlicer-version_2.4.2/src/hints/HintsToPot.cpp: In function ‘bool write_to_pot(boost::filesystem::path, const std::vector<std::pair<std
::__cxx11::basic_string<char>, std::__cxx11::basic_string<char> > >&)’:
/var/tmp/portage/media-gfx/prusaslicer-2.4.2/work/PrusaSlicer-version_2.4.2/src/hints/HintsToPot.cpp:12:21: error: ‘ofstream’ is not a member of ‘boost::filesystem’
   12 |  boost::filesystem::ofstream file(std::move(path), std::ios_base::app);
      |                     ^~~~~~~~


Reproducible: Always

Steps to Reproduce:
1.emerge =prusaslicer-2.4.2
2.
3.
Actual Results:  
Compile error

Expected Results:  
Should compile
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-06-23 20:57:49 UTC
1. Always include the full build.lo and emerge --info.
2. Why aren't you building 2.6.0_pre20220601 which fixes this?
Comment 2 xiaojie+bugzillagentoo 2022-06-23 20:58:51 UTC
Created attachment 787265 [details]
build.log
Comment 3 xiaojie+bugzillagentoo 2022-06-23 20:59:58 UTC
Created attachment 787268 [details]
emerge --info
Comment 4 xiaojie+bugzillagentoo 2022-06-23 21:02:30 UTC
(In reply to Sam James from comment #1)
> 1. Always include the full build.lo and emerge --info.

I was preparing to attach them, you went too fast :-)

> 2. Why aren't you building 2.6.0_pre20220601 which fixes this?

Because it crashes all over the place.
Comment 5 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-06-23 21:19:39 UTC
(In reply to xiaojie+bugzillagentoo from comment #4)
> (In reply to Sam James from comment #1)
> > 1. Always include the full build.lo and emerge --info.
> 
> I was preparing to attach them, you went too fast :-)
> 
> > 2. Why aren't you building 2.6.0_pre20220601 which fixes this?
> 
> Because it crashes all over the place.

Alright, fair enough. It might be a pain to try backport the fixes but they're trivial by themselves (just missing includes). I can try.
Comment 6 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2022-06-23 22:09:21 UTC
It is known that old version do not work with new boost, for that we have a snapshot in tree.

I use it daily and it yet to crash on me. What are the steps to reproduce your crashes? The version 2.4.2 is to be dropped out of tree as a version that do not work with stable boost.

Check if media-gfx/prusaslicer-2.6.0_pre20220620 works better for you.
Comment 7 xiaojie+bugzillagentoo 2022-06-24 04:33:28 UTC
(In reply to Sam James from comment #5)
> (In reply to xiaojie+bugzillagentoo from comment #4)
> > (In reply to Sam James from comment #1)
> > > 1. Always include the full build.lo and emerge --info.
> > 
> > I was preparing to attach them, you went too fast :-)
> > 
> > > 2. Why aren't you building 2.6.0_pre20220601 which fixes this?
> > 
> > Because it crashes all over the place.
> 
> Alright, fair enough. It might be a pain to try backport the fixes but
> they're trivial by themselves (just missing includes). I can try.

Wait a few days, I'm gonna try 2.6.0 again.
Comment 8 xiaojie+bugzillagentoo 2022-06-24 07:17:46 UTC
Closin this bug since 2.4.2_p20220506 (which includes the proper patch for boost) does compile ok, and all following ebuilds too.

This does not solve the slicer crashing, but I'll open a new bug report.