Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 852305 - dev-util/lttng-modules-2.13.3 - /.../tracepoint-event-impl.h: error: conflicting types for trace_sched_switch; have void(bool, str
Summary: dev-util/lttng-modules-2.13.3 - /.../tracepoint-event-impl.h: error: conflict...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Keywords: PullRequest
Depends on:
Reported: 2022-06-16 08:01 UTC by Toralf Förster
Modified: 2022-12-27 10:23 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge-info.txt (emerge-info.txt,19.60 KB, text/plain)
2022-06-16 08:01 UTC, Toralf Förster
dev-util:lttng-modules-2.13.3:20220616-000510.log (dev-util:lttng-modules-2.13.3:20220616-000510.log,8.56 KB, text/plain)
2022-06-16 08:01 UTC, Toralf Förster
emerge-history.txt (emerge-history.txt,217.62 KB, text/plain)
2022-06-16 08:01 UTC, Toralf Förster
environment (environment,91.22 KB, text/plain)
2022-06-16 08:01 UTC, Toralf Förster
etc.portage.tar.bz2 (etc.portage.tar.bz2,13.27 KB, application/x-bzip)
2022-06-16 08:01 UTC, Toralf Förster
temp.tar.bz2 (temp.tar.bz2,22.96 KB, application/x-bzip)
2022-06-16 08:01 UTC, Toralf Förster
ebuild: copied the old, removed the TODO dir (lttng-modules-2.13.7.ebuild,1.03 KB, text/plain)
2022-12-21 17:20 UTC, floatingnebulous

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2022-06-16 08:01:16 UTC
  CC [M]  /var/tmp/portage/dev-util/lttng-modules-2.13.3/work/lttng-modules-2.13.3/src/probes/lttng-probe-sched.o
In file included from /var/tmp/portage/dev-util/lttng-modules-2.13.3/work/lttng-modules-2.13.3/src/probes/../../include/lttng/define_trace.h:87,
                 from /var/tmp/portage/dev-util/lttng-modules-2.13.3/work/lttng-modules-2.13.3/src/probes/../../include/instrumentation/events/sched.h:640,
                 from /var/tmp/portage/dev-util/lttng-modules-2.13.3/work/lttng-modules-2.13.3/src/probes/lttng-probe-sched.c:28:
/var/tmp/portage/dev-util/lttng-modules-2.13.3/work/lttng-modules-2.13.3/src/probes/../../include/lttng/tracepoint-event-impl.h:133:6: error: conflicting types for trace_sched_switch’; have void(bool,  struct task_struct *, struct task_struct *)’ {aka void(_Bool,  struct task_struct *, struct task_struct *)’}
  133 | void trace_##_name(_proto);
      |      ^~~~~~


  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop-j4-20220613-130010


gcc-config -l:
 [1] x86_64-pc-linux-gnu-12.1.1 *
clang/llvm (if any):
clang version 14.0.5
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/14/bin
Python 3.9.13
Available Rust versions:
  [1]   rust-1.61.0 *
The following VMs are available for generation-2:
1)	Eclipse Temurin JDK 11.0.15_p10 [openjdk-bin-11]
*)	Eclipse Temurin JDK 17.0.3_p7 [openjdk-bin-17]
Available Java Virtual Machines:
  [1]   openjdk-bin-11 
  [2]   openjdk-bin-17  system-vm

The Glorious Glasgow Haskell Compilation System, version 8.10.4
php cli:
  [1]   php7.4
  [2]   php8.0
  [3]   php8.1 *

  HEAD of ::gentoo
commit 7f858d6dd1e12d17677840e09f743e102286bccf
Author: Repository mirror & CI <>
Date:   Wed Jun 15 23:33:17 2022 +0000

    2022-06-15 23:33:17 UTC

emerge -qpvO dev-util/lttng-modules
[ebuild  N    ] dev-util/lttng-modules-2.13.3  USE="-dist-kernel"
Comment 1 Toralf Förster gentoo-dev 2022-06-16 08:01:17 UTC
Created attachment 785624 [details]
Comment 2 Toralf Förster gentoo-dev 2022-06-16 08:01:19 UTC
Created attachment 785627 [details]
Comment 3 Toralf Förster gentoo-dev 2022-06-16 08:01:21 UTC
Created attachment 785630 [details]
Comment 4 Toralf Förster gentoo-dev 2022-06-16 08:01:22 UTC
Created attachment 785633 [details]
Comment 5 Toralf Förster gentoo-dev 2022-06-16 08:01:23 UTC
Created attachment 785636 [details]
Comment 6 Toralf Förster gentoo-dev 2022-06-16 08:01:24 UTC
Created attachment 785639 [details]
Comment 7 floatingnebulous 2022-12-21 17:20:12 UTC
Created attachment 844551 [details]
ebuild: copied the old, removed the TODO dir

This ebuild works for me in an overlay. Please complain if it doesn't work for you.  I used "ebuild lttng-modules-<whatever>.ebuild manifest" but there are probably better ways to do this. Read the dev guide.
Comment 8 floatingnebulous 2022-12-21 17:31:53 UTC
I've added an ebuild that works for me. This ebuild only uses a higher version of lttng-modules where the problems you describe should be solved. Please complain if it doesn't.

I did it by setting up an overlay, copying the old "lttng-modules-<old-version>.ebuild" to "lttng-modules-<new-version>.ebuild" into the overlay. Used "ebuild lttng-modules-<new-version>.ebuild manifest" to create a manifest into the repo. Then I emerged it and it worked.
Comment 9 Larry the Git Cow gentoo-dev 2022-12-27 10:23:48 UTC
The bug has been closed via the following commit(s):

commit 5718e87e3541bf83c9f8864a0a7e4fa230255eb3
Author:     Igor V. Kovalenko <>
AuthorDate: 2022-12-24 14:33:57 +0000
Commit:     Sam James <>
CommitDate: 2022-12-27 10:21:45 +0000

    dev-util/lttng-modules: add 2.13.7
    Signed-off-by: Igor V. Kovalenko <>
    Signed-off-by: Sam James <>

 dev-util/lttng-modules/Manifest                    |  1 +
 dev-util/lttng-modules/lttng-modules-2.13.7.ebuild | 49 ++++++++++++++++++++++
 2 files changed, 50 insertions(+)