Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 851051 - >=gnome-base/gvfs-1.50 http USE flag is masked
Summary: >=gnome-base/gvfs-1.50 http USE flag is masked
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-10 17:55 UTC by vincent+gentoo
Modified: 2022-08-07 16:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vincent+gentoo 2022-06-10 17:55:56 UTC
Hello,

Since version 1.50.0, gnome-base/gvfs doesn't have the «http» useflag anymore. It's useful to mount webdav filesystems.

[ebuild     U  ] gnome-base/gvfs-1.50.2::gentoo [1.48.1-r1::gentoo] USE="gnome-keyring gnome-online-accounts mtp nfs policykit systemd udev udisks -afp -archive -bluray -cdda -elogind -fuse -google -gphoto2 (-http*) -ios -samba -test -zeroconf" 0 KiB

thanks
--
vincent


Reproducible: Always

Steps to Reproduce:
1.emerge gnome-base/gvfs-1.50.0
Actual Results:  
/usr/libexec/gvfsd-dav doesn't exist

Expected Results:  
/usr/libexec/gvfsd-dav exists
Comment 1 Mike Gilbert gentoo-dev 2022-06-10 18:39:45 UTC
From profiles/base/package.use.mask:

# Matt Turner <mattst88@gentoo.org> (2022-03-25)
# Depends on libsoup:3.0
>=gnome-base/gvfs-1.50 http
Comment 2 Martin Wohlleben 2022-08-07 11:28:43 UTC
This also prevents Nautilus from mounting Nextcloud shares when a Nexcloud Online Account is define in GNOME settings and the "files" option is activated.

With gnome-base/gvfs-1.48.1-r1 I am able mount my Nextcloud share and with gnome-base/gvfs-1.50.2 Nautilus is failing to mount my Nextcloud share.