Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 850952 - GDM stopped working after upgrade to x11-drivers/nvidia-drivers-510.73.05-r1
Summary: GDM stopped working after upgrade to x11-drivers/nvidia-drivers-510.73.05-r1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ionen Wolkens
Depends on:
Reported: 2022-06-10 07:25 UTC by nE0sIghT
Modified: 2022-06-11 10:55 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

emege --info (emerge-info.log,9.97 KB, text/plain)
2022-06-10 07:25 UTC, nE0sIghT
journalctl --since today (unrelated network etc info cleaned) (journal.log,94.30 KB, text/plain)
2022-06-10 07:26 UTC, nE0sIghT

Note You need to log in before you can comment on or make changes to this bug.
Description nE0sIghT 2022-06-10 07:25:42 UTC
Created attachment 783827 [details]
emege --info

After upgrade to x11-drivers/nvidia-drivers-510.73.05-r1 GDM hangs (black console terminal with _ symbol at top-left conner) with default configuration.

Looking to /lib/udev/rules.d/61-gdm.rules I found that Wayland session is enabled now with 510+ drivers, however it doesn't works for me out of the box.

There is not useful messages in journal as I see.
Comment 1 nE0sIghT 2022-06-10 07:26:32 UTC
Created attachment 783830 [details]
journalctl --since today (unrelated network etc info cleaned)
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-06-10 07:38:16 UTC
Maybe bug 832861?
Comment 3 nE0sIghT 2022-06-10 07:55:01 UTC
A few notes:
1. I have those GLib asserts in both wayland and X11 sessions.
2. Explicitly disabled Wayland session in GDM's custom.conf works for me on 510.
Comment 4 Ionen Wolkens gentoo-dev 2022-06-10 07:56:55 UTC
For nvidia bits, log is essentially saying that nothing went wrong from what I can see, so hard to say.

I did try gdm with 510 in stable before stabilizing and it worked fine here (with wayland, gentoo-kernel-bin-5.15.41 or so, no configuration using out-of-the-box settings).

Could possibly be hardware specific, but I'm not aware of any issues atm given normally gdm auto-disables wayland when it's not working regardless of the udev rules (e.g. for some dual card setups), but otherwise do use it even with nvidia if USE=wayland on nvidia-drivers.
Comment 5 Ionen Wolkens gentoo-dev 2022-06-10 08:02:18 UTC
510 does introduce major changes in that it supports GBM now, which cause certain applications to behave differently (formerly caused a lot more problems, but gnome/kde been rolling out fixes for this). e.g. applications which didn't try to use wayland with 470 may suddenly try to with 510, or use GBM instead of EGLStream (which gnome used to use for wayland with 470).
Comment 6 nE0sIghT 2022-06-11 10:45:16 UTC
I just started to debug it today after world update but found it works now for unknown reason.
Comment 7 Ionen Wolkens gentoo-dev 2022-06-11 10:54:43 UTC
(In reply to nE0sIghT from comment #6)
> I just started to debug it today after world update but found it works now
> for unknown reason.
Strange, but glad to hear it works. Thanks for the update.