Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 850193 - sys-block/gparted-1.5.0-r1 fails test test_SupportedFileSystems when sys-fs/hfsutils is installed
Summary: sys-block/gparted-1.5.0-r1 fails test test_SupportedFileSystems when sys-fs/h...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-06-07 01:44 UTC by Jonathan Lovelace
Modified: 2023-04-02 17:05 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
sys-block:gparted-1.4.0:20220606-163502.log (sys-block:gparted-1.4.0:20220606-163502.log,174.14 KB, text/x-log)
2022-06-07 01:44 UTC, Jonathan Lovelace
Details
emerge-info.txt (emerge-info.txt,8.92 KB, text/plain)
2022-06-07 01:45 UTC, Jonathan Lovelace
Details
test-suite.log (test-suite.log,42.32 KB, text/x-log)
2022-06-07 01:45 UTC, Jonathan Lovelace
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Lovelace 2022-06-07 01:44:56 UTC
Created attachment 783194 [details]
sys-block:gparted-1.4.0:20220606-163502.log

=sys-block/gparted-1.4.0 fails its test suite for me, specifically the test test_SupportedFileSystems. The relevant snippet from the test-suite.log (which I will attach) is:

----
[ RUN      ] My/SupportedFileSystemsTest.CreateAndCheck/hfsplus
test_SupportedFileSystems.cc:631: Failure
Value of: m_fs_object->check_repair(m_partition, m_operation_detail)
  Actual: false
Expected: true
Operation details:
mkfs.hfsplus '/var/tmp/portage/sys-block/gparted-1.4.0/work/gparted-1.4.0/tests/test_SupportedFileSystems.img'
    00:00:00  (SUCCESS)
Initialized /var/tmp/portage/sys-block/gparted-1.4.0/work/gparted-1.4.0/tests/test_SupportedFileSystems.img as
 a 256 MB HFS Plus volume


fsck.hfsplus -f -y '/var/tmp/portage/sys-block/gparted-1.4.0/work/gparted-1.4.0/tests/test_SupportedFileSystem
s.img'    00:00:00  (ERROR)



[  FAILED  ] My/SupportedFileSystemsTest.CreateAndCheck/hfsplus, where GetParam() = 16 (62 ms)
----

I have not yet tried installing sys-fs/hfsplusutils (the last time I remember investigating this test failure was before the ~amd64 KEYWORD was added to that package in 2019).
Comment 1 Jonathan Lovelace 2022-06-07 01:45:17 UTC
Created attachment 783197 [details]
emerge-info.txt
Comment 2 Jonathan Lovelace 2022-06-07 01:45:33 UTC
Created attachment 783200 [details]
test-suite.log
Comment 3 Jonathan Lovelace 2023-04-02 17:05:55 UTC
I'm still seeing this in version 1.5.0-r1. And I now have sys-fs/hfsplusutils    installed, but that doesn't seem to have helped.