Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 84571 - nvidia causes freeze on ACPI event in 2.6.11 (i8500 laptop)
Summary: nvidia causes freeze on ACPI event in 2.6.11 (i8500 laptop)
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: X11 External Driver Maintainers
Depends on:
Reported: 2005-03-08 17:00 UTC by Kyle
Modified: 2006-03-25 14:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Kyle 2005-03-08 17:00:34 UTC
when running acpid -d in 2.6.10-rc7, and I press the lid, I can see the results and all works great and dandy, I then tried moving up to 2.6.11 (using gentoo-dev-sources and brix's suspend-sources) and all of the sudden it broke. Any time I press it my computer immediately freezes. when I switch back to 2.6.10-rc7 it works fine again.

I would send an error log but as it freezes immediately there aren't any errors, I checked the logs

Reproducible: Always
Steps to Reproduce:
1. press the lid button

Expected Results:  
acpid is able to catch the event and my system suspends

configuration files at:
Comment 1 Micheal Marineau (RETIRED) gentoo-dev 2005-03-08 21:41:16 UTC
Does the freeze indeed happen before acpid catches the event? if you comment out the lid button code in your acpid script does it still lock up?
Comment 2 Kyle 2005-03-10 20:25:45 UTC
I don't even have to have acpid running to have it freeze.
Comment 3 Micheal Marineau (RETIRED) gentoo-dev 2005-03-11 08:55:07 UTC
hmm, not sure, I have the same laptop but have no problems at all.  What kernel are you currently using a could you attach your .config file? Thanks
Comment 4 Kyle 2005-03-11 12:57:13 UTC
All related files are at
That's all of my current kernel configs.
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2005-03-12 17:01:48 UTC
Does this happen on plain gentoo-dev-sources or only when it is patched with suspend2?
Comment 6 Kyle 2005-03-14 15:41:36 UTC
both gentoo-dev-sources and suspend sources. I just tried remaking a new 2.6.11 kernel from gentoo-dev-sources and it still doesn't work, just freezes :/
Comment 7 Daniel Drake (RETIRED) gentoo-dev 2005-03-16 06:33:16 UTC
Hm, thats a bit awkward to debug. Could you please test the latest 2.6.11-mm version just incase its already been fixed?
Comment 8 Micheal Marineau (RETIRED) gentoo-dev 2005-03-16 11:04:18 UTC
I've tried your kernel config and still can't reproduce this problem at all.  Am I correct in guessing that you have the Nvidia card? I have the Ati video card so perhaps your issue is related to that difference.  Do you use the nvidia driver? and if so, what happens if the nvidia kernel modules is not loaded?
Comment 9 Kyle 2005-03-20 11:25:43 UTC
I do indeed have the nvidia card, and no, -mm4 doesn't work, it still freezes the whole computer. I'll post my current kernel config at in a few.
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2005-03-20 11:45:21 UTC
Do you use the nvidia driver? and if so, what happens if the nvidia kernel modules is not loaded?
Does X running (or not) make any difference?
Comment 11 Kyle 2005-03-20 12:23:41 UTC
aha, it is the nvidia driver, I can't believe I didn't think of that earlier. it works with it not loaded, doesn't with it loaded. Any suggestions there? or is that one of those, just wait for nvidia, type things
Comment 12 Daniel Drake (RETIRED) gentoo-dev 2005-03-20 14:24:49 UTC
I'm sure the nvidia maintainers will love to hear they've got another closed-source driver issue on their hands :)

Kyle, could you please try different versions of the driver? There should be at least two in portage that work with 2.6.11
Comment 13 Jeremy Huddleston (RETIRED) gentoo-dev 2006-03-24 15:13:34 UTC
Well there's been no response for the past year here, so closing.  If you still have the problem with recent driver versions, please reopen and report versions of the kernel and driver here
Comment 14 . 2006-03-25 07:36:46 UTC
The computer that I was having that problem on completely died so I sent it back to dell and got a new one, so I won't be able to provide any more info. should've closed it sooner :/
Comment 15 Kris Kersey (RETIRED) gentoo-dev 2006-03-25 14:29:06 UTC
Closed per reporter comment.