Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 84464 - mozilla-firefox-1.0.1 emerge segfaults
Summary: mozilla-firefox-1.0.1 emerge segfaults
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-07 19:55 UTC by Whit Blauvelt
Modified: 2005-11-17 15:04 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Whit Blauvelt 2005-03-07 19:55:55 UTC
Error arises here:

c++ -o nsFontMetricsXft.o -c -DNATIVE_THEME_SUPPORT -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\" -DUSE_POSTSCRIPT -I../.. -I./. -I./.. -I./../shared -I./../freetype -I./../x11shared -I/usr/X11R6/include -I/usr/include/freetype2 -I/usr/include/freetype2/config    -I../../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/widget -I../../../dist/include/view -I../../../dist/include/util -I../../../dist/include/pref -I../../../dist/include/uconv -I../../../dist/include/unicharutil -I../../../dist/include/locale -I../../../dist/include/necko -I../../../dist/include/content -I../../../dist/include/dom -I../../../dist/include/layout -I../../../dist/include/imglib2 -I../../../dist/include/gfx -I../../../dist/include -I/var/tmp/portage/mozilla-firefox-1.0.1/work/mozilla/dist/include/nspr     -I/usr/include/freetype2 -I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -fno-rtti -fno-exceptions  -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -march=athlon-xp -fstack-protector -pipe -Wno-deprecated -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -ffunction-sections -O2  -DXTHREADS -D_REENTRANT -DXUSE_MTSAFE_API -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/X11R6/include -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/freetype2/config -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include    -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/nsFontMetricsXft.pp nsFontMetricsXft.cpp
{standard input}: Assembler messages:
{standard input}:15992: Warning: end of file not at end of a line; newline inserted
c++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See <URL:http://bugs.gentoo.org/> for instructions.
gmake[4]: *** [nsFontMetricsGTK.o] Error 1
gmake[4]: *** Deleting file `nsFontMetricsGTK.o'
gmake[4]: *** Waiting for unfinished jobs....
gmake[4]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.1/work/mozilla/gfx/src/gtk'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.1/work/mozilla/gfx/src'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.1/work/mozilla/gfx'
gmake[1]: *** [tier_9] Error 2
gmake[1]: Leaving directory `/var/tmp/portage/mozilla-firefox-1.0.1/work/mozilla'
make: *** [default] Error 2

!!! ERROR: net-www/mozilla-firefox-1.0.1 failed.
!!! Function src_compile, Line 105, Exitcode 2


Reproducible: Always
Steps to Reproduce:
1.
2.
3.




# emerge info
Portage 2.0.51.19 (default-linux/x86/2004.0, gcc-3.3.5, glibc-2.3.4.20040808-r1,
2.6.9-win4lin-r6n i686)
=================================================================
System uname: 2.6.9-win4lin-r6n i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.2.3-r5,dev-lang/python-2.3.4-r1 [2.3.4
(#1, Feb 14 2005, 15:45:56)]
dev-lang/python:     2.2.3-r5, 2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.4.19-r1, 2.4.21-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -fprefetch-loop-arrays
-funroll-loops -fstack-protector -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env
/usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config
/usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O2 -fomit-frame-pointer -fprefetch-loop-arrays
-funroll-loops -fstack-protector -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org
http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups curl emboss
encode esd f77 fam flac font-server foomaticdb fortran gdbm gif gpm gtk gtk2
guile imagemagick imlib ipv6 java jpeg kde libg++ libwww mad mbox mikmod motif
mozilla mp3 mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png
python qt quicktime readline samba sdl slang spell ssl svga tcltk tcpd tetex
tiff truetype truetype-fonts type1-fonts xml xml2 xmms xv zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Jory A. Pratt 2005-11-17 13:51:01 UTC
is this still an issue or can we close?
Comment 2 Whit Blauvelt 2005-11-17 15:04:10 UTC
Closing because obsolete.