Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 841137 - app-portage/gentoolkit-0.5.1-r1 QA: prepare Non-PEP517 builds are deprecated for ebuilds using plain distutils.
Summary: app-portage/gentoolkit-0.5.1-r1 QA: prepare Non-PEP517 builds are deprecated ...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage Tools Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-26 18:09 UTC by Kim B. Sindalsen
Modified: 2022-06-04 13:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kim B. Sindalsen 2022-04-26 18:09:44 UTC
QA: prepare
Non-PEP517 builds are deprecated for ebuilds using plain distutils.
Please migrate to DISTUTILS_USE_PEP517=setuptools.
Please see Python Guide for more details:
  https://projects.gentoo.org/python/guide/distutils.html


Reproducible: Always

Steps to Reproduce:
1. emerge
2.
3.