Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 840221 - www-apps/nextcloud-23.0.3: not compatible with dev-lang/php:8.1
Summary: www-apps/nextcloud-23.0.3: not compatible with dev-lang/php:8.1
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-22 20:30 UTC by Alexandra Parker
Modified: 2022-04-23 15:49 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandra Parker 2022-04-22 20:30:21 UTC
I'm running a ~ keyword system, so www-apps/nextcloud RDEPEND on dev/lang-php resolves to dev-lang/php-8.1.4. At runtime it checks (lib/versioncheck.php) that it's not running on PHP>8.0 and crashes otherwise, so it should probably RDEPEND on dev-lang/php<8.1.

Reproducible: Always

Steps to Reproduce:
1. Be ~ARCH.
2. Install nextcloud.
3. Try to access nextcloud.
Actual Results:  
Page saying:

This version of Nextcloud is not compatible with > PHP 8.0.
You are currently running 8.1.4.

Expected Results:  
Nextcloud homepage.

Running on ~arm64. Can work around by either masking PHP 8.1 if nothing needs it, or also installing 8.0 otherwise. Is there a better workaround to mask 8.1 for www-apps/nextcloud specifically?