Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 837875 - app-text/texlive-core-2021-r1 fails to reinstall - missing mplib.h
Summary: app-text/texlive-core-2021-r1 fails to reinstall - missing mplib.h
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: parallel-make
  Show dependency tree
 
Reported: 2022-04-11 19:10 UTC by Helmut Jarausch
Modified: 2022-04-30 01:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (texlive-core.info,21.28 KB, text/plain)
2022-04-11 19:10 UTC, Helmut Jarausch
Details
build log xz-compressed (texlive-core-2021-r1.build.xz,32.46 KB, application/octet-stream)
2022-04-12 14:28 UTC, Helmut Jarausch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Jarausch 2022-04-11 19:10:13 UTC
Created attachment 770144 [details]
emerge --info

I try to reinstall app-text/texlive-core-2021-r1, but it fails with
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I/var/tmp/portage/app-text/texlive-core-2021-r1/work/texlive-20210325-source/texk/web2c \
   -I./w2c    -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi/include \
   -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/libpng16  -I/usr/include/pixman-1  \
   -I/usr/include/libpng16    -I/var/tmp/portage/app-text/texlive-core-2021-r1/work/texlive-20210325-source/texk/web2c/mplibdir  \
   -Wimplicit -Wreturn-type -march=native -O3 -pipe -c -o libmplibbackends_a-pngout.o `test -f 'pngout.c' \
   || echo '/var/tmp/portage/app-text/texlive-core-2021-r1/work/texlive-20210325-source/texk/web2c/'`pngout.c
/var/tmp/portage/app-text/texlive-core-2021-r1/work/texlive-20210325-source/texk/web2c/mplibdir/pngout.w:63:10: fatal error: mplib.h: No such file or directory
   63 | #include "mplib.h"
      |          ^~~~~~~~~

What has happened?
Many thanks for a hint,
Helmut
Comment 1 Mike Gilbert gentoo-dev 2022-04-11 19:25:53 UTC
Please attach a full build log and change the bug status back to UNCONFIRMED.
Comment 2 Helmut Jarausch 2022-04-12 14:28:22 UTC
Created attachment 770375 [details]
build log  xz-compressed
Comment 3 Helmut Jarausch 2022-04-19 11:16:00 UTC
This is a problem of incorrect parallel make.

Setting OPT='-j1' fixes this.

(I should have tried that)