Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 837710 - app-text/zathura man pages are not build unless the "doc" USE flag is set
Summary: app-text/zathura man pages are not build unless the "doc" USE flag is set
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Piotr Karbowski
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-10 19:38 UTC by Jorge Almeida
Modified: 2023-01-20 12:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Almeida 2022-04-10 19:38:03 UTC
app-text/zathura: man pages are not build unless the "doc" USE flag is set. man/info pages are supposed to be installed by default, whereas "doc" would add *extra* documentation
Comment 1 Bogdan 2022-06-11 14:43:22 UTC
confirm.
I need man pages without extra documentation.
Comment 2 Bogdan 2022-06-11 14:53:59 UTC
tool rst2man (/usr/bin/rst2man.py) is a part of dev-python/docutils package.

Man pages may be installed manual by next commands in ebuild:

  for frst in $(find doc/man/ -name "*.rst"); do
    fman=$(echo $frst | awk -F ".rst" '{print $1".n"}')
    rst2man.py $frst > $fman
  done
  doman -r doc/man/*.n
Comment 3 Larry the Git Cow gentoo-dev 2023-01-08 21:14:14 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=49d0d0d9732024b1d5636a341feb7a977282014d

commit 49d0d0d9732024b1d5636a341feb7a977282014d
Author:     Piotr Karbowski <slashbeast@gentoo.org>
AuthorDate: 2023-01-08 21:12:50 +0000
Commit:     Piotr Karbowski <slashbeast@gentoo.org>
CommitDate: 2023-01-08 21:14:12 +0000

    app-text/zathura: 0.5.2-r2, 9999: install man pages unconditionally.
    
    And by extension drop 'doc' USE flag, since the meson.build there is
    limited to only man pages anyway.
    
    Closes: https://bugs.gentoo.org/837710
    Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>

 .../zathura/{zathura-0.5.2-r1.ebuild => zathura-0.5.2-r2.ebuild}    | 6 +++---
 app-text/zathura/zathura-9999.ebuild                                | 6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)
Comment 4 Nickolas Raymond Kaczynski 2023-01-20 10:17:20 UTC
Hi,

I'm not a fan of this change because of the added dependency. `dev-util/perf` for example also doesn't install manpage without the `doc` USEFLAG because generating the docs adds extra dependency.

And this doesn't seem to be an uncommon thing either:

	$ quse -D doc | grep 'man'
	dev-util/buildbot[docker] Add support for worker docker command steps
	dev-util/perf[doc] Build documentation and man pages. With this USE flag disabled, the --help parameter for perf and its sub-tools will not be available. This is optional because it depends on a few documentation handling tools that are not always welcome on user systems.
	mail-client/alot[doc] Install user manual and API documentation
	net-firewall/nftables[doc] Create man pages for the package (requires app-text/asciidoc)
	sys-apps/earlyoom[docs] Generate man page
	sys-devel/llvm[doc] Build and install the HTML documentation and regenerate the man pages
	x11-misc/alock[doc] Build and install manpage with app-text/asciidoc.
	x11-misc/picom[doc] Build documentation and man pages (requires app-text/asciidoc)
	x11-wm/i3[doc] Build and install the HTML documentation and regenerate the man pages
	gui-apps/wlogout[doc] Install man pages
	x11-misc/picom-jonaburg[doc] Build documentation and man pages (requires app-text/asciidoc)
Comment 5 Nickolas Raymond Kaczynski 2023-01-20 10:36:03 UTC
According to the policy (https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0305) if building manpage requires extra dependencies then the maintainer needs build the manpages and ship that instead. (Thanks to ionen for pointing this out in IRC).
Comment 6 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2023-01-20 12:18:41 UTC
Sphinx dependency will be dropped soon, see https://bugs.gentoo.org/890589

And to be true to actual policy, it says 'should' not 'needs' which leaves a lot to individual interpretation.