Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 837365 - net-vpn/networkmanager-vpnc-1.2.8 fails to compile: nm-default.h:49:10: fatal error: nm-version.h: No such file or directory
Summary: net-vpn/networkmanager-vpnc-1.2.8 fails to compile: nm-default.h:49:10: fatal...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: missing-depend
  Show dependency tree
 
Reported: 2022-04-09 11:05 UTC by Agostino Sarubbo
Modified: 2023-02-06 10:04 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,72.66 KB, text/plain)
2022-04-09 11:05 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2022-04-09 11:05:29 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-vpn/networkmanager-vpnc-1.2.8 fails to compile.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2022-04-09 11:05:31 UTC
Created attachment 769595 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2022-04-09 11:05:32 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:


./shared/nm-default.h:49:10: fatal error: nm-version.h: No such file or directory
./shared/nm-default.h:49:10: fatal error: nm-version.h: No such file or directory
Comment 3 Ghiunhan Mamut 2022-04-17 10:59:44 UTC
enabling USE=gtk pulls in net-libs/libnma which allows the build to succeed
Comment 4 Jan-Matthias Braun 2022-04-24 15:16:34 UTC
On my system, libnma was already installed and didn't allow the build to succeed on its own.

According to the ebuild, the gtk USE flag enables the configure option "--with-gtk4". But on my system, the linked libraries always include gtk3, no matter what, the with-gtk4 option has no effect on the gtk version linked against.

In my tests, the ebuild will comple as soon as the
                $(use_with gtk gnome) \
line is removed from the ebuild. But the linked to gtk version of the connection editor is independent of the gtk use flag.

To me it seems like the current use flag configuration is not doing what it should for version 1.2.8, but I also don't know how to fix it.
Comment 5 Alexander Wetzel 2022-04-30 17:26:09 UTC
USE=gtk emerge -1av net-vpn/networkmanager-vpnc worked for me, too,

Issue seems to be known upstream but looks not very active:
https://gitlab.gnome.org/GNOME/NetworkManager-vpnc/-/issues/7

Builds are failing for "--with-gtk4" and also "--without-gnome" according to that. And the error for "--without-gnome" locks *very* similar to our one here...

Only solution provided upstream so far:
"Looks like only solution is install gtk+3.0 however none of the produced binaries depends on gtk in any version so looks like using direct build dependencies."
Comment 6 Eddie Chapman 2022-06-09 10:42:31 UTC
Just reporting that adding the gtk use flag resolved the issue (nm-version.h: No such file or directory) for me, it pulled in net-libs/libnma and allowed the build to complete.

For reference, the failed build ./configure was:
./configure <snip, same in both cases> --without-gnome --without-gtk4 --without-libnm-glib

and the successful build ./configure was:
./configure <snip, same in both cases> --with-gnome --with-gtk4 --without-libnm-glib
Comment 7 Giorgio Premi 2022-09-02 07:42:54 UTC
I can confirm the above issues and workaround.

It's been a while that net-vpn/networkmanager-vpnc-1.2.8 failed to compile for me. By adding the gtk use flag pulled in `gui-libs/gtk-4.6.6:4::gentoo`, which allows it to compiled ok (as a side note, I have x11-libs/gtk+ 2.24.33 and 3.24.34 installed).

I've tried to patch autoconf myself, but failed as my understanding isn't so deep. The actual issue is that the include option `-I/usr/include/libnm` (and some other glib related) are not added to the compilation of file auth-dialog/main.c, but are available to all other Makefile rules *.c->*.o.


On upstream I found this issue https://gitlab.gnome.org/GNOME/NetworkManager-vpnc/-/issues/7 with some more infos and logs.


Would it be a good temporary workaround to force the gtk use flag in portage?