Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 8372 - vim-6.1-r13 patch failed during update
Summary: vim-6.1-r13 patch failed during update
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 All
: High critical (vote)
Assignee: Ryan Phillips (RETIRED)
: 8389 (view as bug list)
Depends on: 8400
  Show dependency tree
Reported: 2002-09-25 11:17 UTC by Dan Noe
Modified: 2003-02-04 19:42 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Dan Noe 2002-09-25 11:17:57 UTC
During a world update, a patch to the vim source failed:

Applying patch /var/tmp/portage/vim-6.1-r13/work/6.1.001...patch: **** 
replacement text or line numbers mangled in hunk at line 22

!!! ERROR: The ebuild did not complete successfully.
!!! Function src_unpack, Line -15, Exitcode 2
!!! (no error message)

I am using diffutils-2.8.4.
Comment 1 Jon Nelson (RETIRED) 2002-09-25 21:39:10 UTC
*** Bug 8389 has been marked as a duplicate of this bug. ***
Comment 2 Jon Nelson (RETIRED) 2002-09-25 21:41:22 UTC
I am using diffutils 2.7.7 and it appears to be working fine.
Could it be diffutils?

I'll manually install 2.8.4 to see.
Comment 3 Jon Nelson (RETIRED) 2002-09-25 21:51:12 UTC
diffutils 2.8.4 seems to work just fine for me.
Comment 4 Hannes Mehnert (RETIRED) gentoo-dev 2002-09-25 21:59:21 UTC
maybe your ${FILESIDR}/vimpatch.tar.bz2 is corrupt? please delete it and do an 
emerge sync with the new rsynced vimpatch.tar.bz2. 
Comment 5 Dan Noe 2002-09-25 22:09:58 UTC
Deleted vimpatch.tar.bz2, re-synced the tree, still getting the same problem :(

I had a similar problem with tetex, same machine.  Any other ideas?

Bit of the patch/line number in question (I could attach the whole file, as 
well, if you want, but it looks alright to me.):

20: --- src/edit.c  Wed Mar 27 19:25:13 2002
21: ***************
22: *** 3669,3674 ****
23: --- 3669,3680 ----
Comment 6 Jon Nelson (RETIRED) 2002-09-25 22:47:06 UTC
What's the md5sum of vimpatch.tar.bz2 and 6.1_patches.80.84.diff ?

6e3418258a9973a532d1703544411fa1  vimpatch.tar.bz2
38ae3423789e097a1fc2ed45b0a342f0  6.1_patches.80.84.diff

Comment 7 Spider (RETIRED) gentoo-dev 2002-09-25 23:18:09 UTC
38ae3423789e097a1fc2ed45b0a342f0  6.1_patches.80.84.diff
6e3418258a9973a532d1703544411fa1  vimpatch.tar.bz2


*  sys-apps/diffutils
      Latest version available: 2.8.4
      Latest version installed: 2.7.7
      Description: Tools to make diffs and compare files
Comment 8 Spider (RETIRED) gentoo-dev 2002-09-25 23:34:10 UTC
i just updated diffutils. same error
Comment 9 Jon Nelson (RETIRED) 2002-09-26 00:41:53 UTC
And I'm completely up to date with *no* problems.
Comment 10 Ryan Phillips (RETIRED) gentoo-dev 2002-09-26 01:06:32 UTC
Brett has submitted a new patches for vim upto 197.... Can you guys test?
Comment 11 Ryan Phillips (RETIRED) gentoo-dev 2002-09-26 01:12:10 UTC
oops forgot... see bug #8400 for the patch file
Comment 12 Dan Noe 2002-09-27 10:58:47 UTC
I have the correct md5sums for both.  I've removed both files and resynced
the portage tree.  Now emerge -p -u vim shows an upgrade to python and tk 

Same problem;

Applying patch /var/tmp/portage/vim-6.1-r13/work/6.1.001...patch: **** 
replacement text or line numbers mangled in hunk at line 22

Is there some reason why the most recent diffutils would have problems?
The tetex package has generated similar errors, but only certain versions.
When I submitted a bug report, it was recommended that I unmask a more recent
version of tetex and try.  Sure enough, it worked, but the next time tetex was
updated along with world, it wouldn't patch.  Spider, can you merge the latest
Comment 13 Spider (RETIRED) gentoo-dev 2002-09-27 17:07:14 UTC
re-emerge of patch and diffutils with -O2 instead of -O3 solved this

gcc 3.2 , please note, -O3 can bring failures