Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 835855 - games-puzzle/atomix-3.34.0-r1 fails to compile: meson.build:21:0: ERROR: Dependency "libgnome-games-support-1" not found, tried pkgconfig and cmake
Summary: games-puzzle/atomix-3.34.0-r1 fails to compile: meson.build:21:0: ERROR: Depe...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-23 14:59 UTC by Agostino Sarubbo
Modified: 2023-03-12 06:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,48.71 KB, text/plain)
2022-03-23 14:59 UTC, Agostino Sarubbo
Details
1-meson-log.txt (1-meson-log.txt,12.28 KB, text/plain)
2022-03-23 14:59 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2022-03-23 14:59:31 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: games-puzzle/atomix-3.34.0-r1 fails to compile.
Discovered on: amd64 (internal ref: tinderbox_musl)

NOTE:
This machine uses MUSL libc
Comment 1 Agostino Sarubbo gentoo-dev 2022-03-23 14:59:33 UTC
Created attachment 767654 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2022-03-23 14:59:34 UTC
Created attachment 767655 [details]
1-meson-log.txt

1-meson-log.txt
Comment 3 Agostino Sarubbo gentoo-dev 2022-03-23 14:59:35 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:


Run-time dependency libgnome-games-support-1 found: NO (tried pkgconfig and cmake)
meson.build:21:0: ERROR: Dependency "libgnome-games-support-1" not found, tried pkgconfig and cmake
Comment 4 Michal Plichta 2022-05-29 21:50:54 UTC
emerge -c just clean up libgnome-games-support 

$ eix libgnome-games-support
[I] dev-libs/libgnome-games-support
     Available versions:  
     (1)    1.8.2(1/3)
     (2)    2.0.0(2/4)
     Installed versions:  2.0.0(2/4)(03:24:08 PM 05/28/2022)
     Homepage:            https://gitlab.gnome.org/GNOME/libgnome-games-support
     Description:         Library for code common to GNOME games


since atomic has:
RDEPEND="
    >=x11-libs/gtk+-3.10:3
    >=x11-libs/gdk-pixbuf-2.0.5:2
    >=dev-libs/glib-2.36.0:2
    dev-libs/libgnome-games-support:=
"

after emergeing libgnome-games-support:1 atomix compile fine but 
$ sudo emerge -pc
>>> These are the packages that would be unmerged:

 dev-libs/libgnome-games-support
    selected: 1.8.2 
   protected: none 
     omitted: 2.0.0 

All selected packages: =dev-libs/libgnome-games-support-1.8.2

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Packages installed:   1972
Packages in world:    271
Packages in system:   43
Required packages:    1971
Number to remove:     1
Comment 5 Alexis 2023-03-12 06:23:31 UTC
Modifying upstream's `meson.build` to replace the reference to `libgnome-games-support-1` with `libgnome-games-support-2` (i.e. after an `ebuild prepare` but before an `ebuild merge`) results in a successful merge for me, and the game seems to run successfully in initial testing.

Atomix seems to be the only dependent of libgnome-games-support:

    # equery d libgnome-games-support
     * These packages depend on libgnome-games-support:
    games-puzzle/atomix-3.34.0-r1 (dev-libs/libgnome-games-support)
    #