Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 83554 - USE flags for wxpython changed to "+unicode" and emerge --newuse didn't want to rebuild wxGTK
Summary: USE flags for wxpython changed to "+unicode" and emerge --newuse didn't want ...
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-28 06:52 UTC by Francisco Ares
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Ares 2005-02-28 06:53:09 UTC
I've changed /etc/portaga/package.use USE flags for wxpython to include "unicode", and when I thied an 

emerge -vD --newuse wxpython

during compilation, it complained about the need to do the same thing to wxGTK, i.e., change the USE flags.
Comment 1 Sven Wegener gentoo-dev 2005-02-28 07:08:37 UTC
/etc/portage/package.use is for specifying USE-flags on a per package or even
per version level. If you add "dev-python/wxpython unicode" to this file,
portage will only turn the USE flag on for this particular package. It doesn't
know about the fact that x11-libs/wxGTK also needs to be built with
USE="unicode" support. You need to add the line "x11-libs/wxGTK unicode" to
package.use or add unicode to USE in make.conf or wait until portage has support
for USE depends.

*** This bug has been marked as a duplicate of 2272 ***