Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 832582 - sci-mathematics/ginac-1.8.2 fails to compile: error: Problems running latex Check your installation or look for typos in _formulas.tex and check _formulas.log!
Summary: sci-mathematics/ginac-1.8.2 fails to compile: error: Problems running latex C...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-02 14:06 UTC by Agostino Sarubbo
Modified: 2023-04-13 10:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,201.68 KB, text/plain)
2022-02-02 14:06 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2022-02-02 14:06:24 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: sci-mathematics/ginac-1.8.2 fails to compile.
Discovered on: amd64 (internal ref: ci)

NOTE:
If you think this is a GCC-11 related issue, please block bug 732706.
Comment 1 Agostino Sarubbo gentoo-dev 2022-02-02 14:06:26 UTC
Created attachment 764225 [details]
build.log

build log and emerge --info
Comment 2 Agostino Sarubbo gentoo-dev 2022-02-02 14:06:27 UTC
Error(s) that match a know pattern in addition to what has been reported in the summary:


! LaTeX Error: File `varwidth.sty' not found.
error: Problems running latex. Check your installation or look for typos in _formulas.tex and check _formulas.log!
Comment 3 Larry the Git Cow gentoo-dev 2022-02-02 15:40:42 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=e04e32a6bd15efb28be9a2cbf9a3ccceb2e63705

commit e04e32a6bd15efb28be9a2cbf9a3ccceb2e63705
Author:     Andrey Grozin <grozin@gentoo.org>
AuthorDate: 2022-02-02 15:40:15 +0000
Commit:     Andrey Grozin <grozin@gentoo.org>
CommitDate: 2022-02-02 15:40:15 +0000

    sci-mathematics/ginac: ginac-1.8.2[doc] DEPENDs on texlive-latexextra
    
    Bug: https://bugs.gentoo.org/832582
    Package-Manager: Portage-3.0.30, Repoman-3.0.3
    Signed-off-by: Andrey Grozin <grozin@gentoo.org>

 sci-mathematics/ginac/ginac-1.8.2.ebuild | 1 +
 1 file changed, 1 insertion(+)
Comment 4 Andrey Grozin gentoo-dev 2022-02-02 15:45:52 UTC
Please check the new version.
For me, ginac[doc] builds fine, but I have a lot of latex packages. E.g., varwidth.sty belongs to texlive-latexextra. In ginac-1.8.2 .tex file are produced on the fly; I cannot just check what \usepackage-s are contained in them and to deduce theoretically which dependencies are really necessary. So, the only way is experimental - if somebody with few texlive packages installed tries to build ginac-1.8.2[doc].
Comment 5 David Seifert gentoo-dev 2023-04-13 10:09:57 UTC
(In reply to Andrey Grozin from comment #4)
> Please check the new version.
> For me, ginac[doc] builds fine, but I have a lot of latex packages. E.g.,
> varwidth.sty belongs to texlive-latexextra. In ginac-1.8.2 .tex file are
> produced on the fly; I cannot just check what \usepackage-s are contained in
> them and to deduce theoretically which dependencies are really necessary.
> So, the only way is experimental - if somebody with few texlive packages
> installed tries to build ginac-1.8.2[doc].

Then remove all of (la)tex, and start by adding virtual/latex-base and all the other packages to get it to work?