Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 832047 - kde-plasma/kscreen w/ >=x11-base/xorg-server-21.1: kscreen_backend segfault in
Summary: kde-plasma/kscreen w/ >=x11-base/xorg-server-21.1: kscreen_backend segfault i...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
: 831846 (view as bug list)
Depends on:
Reported: 2022-01-25 14:51 UTC by b2c
Modified: 2022-03-31 20:39 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (file_832047.txt,5.46 KB, text/plain)
2022-01-25 14:51 UTC, b2c
dmesg kscreen segfault (file_832047.txt,101.56 KB, text/plain)
2022-01-25 14:52 UTC, b2c
config-5.10.93-gentoo (file_832047.txt,134.68 KB, text/plain)
2022-01-25 14:53 UTC, b2c
config-5.15.16-gentoo (file_832047.txt,139.44 KB, text/plain)
2022-01-25 14:55 UTC, b2c
backtrace from /usr/lib64/libexec/kf5/kscreen_backend_launcher (backtrace-kscreen_backend.txt,20.32 KB, text/plain)
2022-03-31 20:33 UTC, b2c

Note You need to log in before you can comment on or make changes to this bug.
Description b2c 2022-01-25 14:51:12 UTC
Created attachment 763615 [details]
emerge --info

Since a recent update I can't login to KDE anymore since it crashes after I input the credentials in SDDM. In dmesg I can see that it logs a segfault:

[Tue Jan 25 15:20:04 2022] kscreen_backend[6550]: segfault at 8 ip 00007f06e0e583cd sp 00007ffd4535baf0 error 4 in[7f06e0e55000+19000]

I have tried to roll back to an older kernel or video driver (nvidia), but to no avail.

Tested combinations that produce the crash:

gentoo-sources: 5.10.93 & 5.15.16
nvidia-drivers: 495.46-r10 & 510.39.01

I have already tried to recompile world etc. Any idea what might be the issue here? doesn't seem to be the hardware, I tested with an Arch Linux installation and it doesn't crash.
Comment 1 b2c 2022-01-25 14:52:59 UTC
Created attachment 763616 [details]
dmesg kscreen segfault
Comment 2 b2c 2022-01-25 14:53:52 UTC
Created attachment 763617 [details]
Comment 3 b2c 2022-01-25 14:55:03 UTC
Created attachment 763618 [details]
Comment 4 b2c 2022-01-26 09:41:38 UTC
Ok, thanks for the link, at least I'm not the only one with this kind of issue. I tried fiddling around a little bit more with modeset, e.g. setting 

options nvidia-drm modeset=0

in /etc/modprobe.d/nvidia.conf , but it didn't help so far.
Comment 5 b2c 2022-01-27 15:53:26 UTC
I have backtracked the merge that made things break, and it seems it happened on 2022-01-21.
There are a couple of KDE 5.90 packages in there that came from the kde-overlay which I have rolled back to stable since then (didn't change the kscreen segfault though). Prime suspect probably is x11-base/xorg-server-21.1.3 and its dependencies?

merge history from 2022-01-21:
2022-01-21T09:17:17 >>> x11-base/xorg-drivers-21.1
2022-01-21T09:17:39 >>> sys-kernel/gentoo-sources-5.15.16
2022-01-21T09:18:40 >>> dev-libs/libgcrypt-1.9.4
2022-01-21T09:19:17 >>> x11-misc/compose-tables-1.7.3
2022-01-21T09:19:30 >>> x11-libs/libX11-1.7.3
2022-01-21T09:20:04 >>> sys-libs/talloc-2.3.3
2022-01-21T09:20:58 >>> sys-libs/tevent-0.11.0
2022-01-21T09:21:56 >>> dev-util/meson-0.60.3
2022-01-21T09:22:06 >>> x11-libs/libxcvt-0.1.1
2022-01-21T09:22:14 >>> x11-base/xorg-server-21.1.3
2022-01-21T09:22:36 >>> dev-python/cython-0.29.26
2022-01-21T09:22:59 >>> x11-drivers/xf86-video-vesa-2.5.0
2022-01-21T09:23:10 >>> dev-python/numpy-1.21.5
2022-01-21T09:26:28 >>> dev-util/wayland-scanner-1.20.0
2022-01-21T09:26:38 >>> dev-libs/wayland-1.20.0
2022-01-21T09:26:49 >>> dev-libs/wayland-protocols-1.24
2022-01-21T09:26:57 >>> media-libs/libglvnd-1.4.0
2022-01-21T09:27:12 >>> x11-libs/libdrm-2.4.109
2022-01-21T09:27:27 >>> media-libs/mesa-21.3.4
2022-01-21T09:28:50 >>> dev-qt/qtcore-5.15.2-r14
2022-01-21T09:30:24 >>> gui-libs/egl-wayland-1.1.9_p20211123
2022-01-21T09:30:33 >>> dev-libs/libevdev-1.12.0
2022-01-21T09:30:44 >>> sys-libs/ldb-2.4.1
2022-01-21T09:31:55 >>> dev-qt/qtnetwork-5.15.2-r14
2022-01-21T09:32:38 >>> x11-apps/xauth-1.1.1
2022-01-21T09:32:48 >>> x11-drivers/xf86-input-evdev-2.10.6
2022-01-21T09:32:59 >>> x11-libs/libva-2.13.0-r2
2022-01-21T09:33:22 >>> x11-drivers/xf86-input-libinput-1.2.0
2022-01-21T09:45:12 >>> dev-qt/qtgui-5.15.2-r16
2022-01-21T09:47:03 >>> dev-qt/qtsvg-5.15.2-r13
2022-01-21T09:47:18 >>> dev-qt/qtwayland-5.15.2-r17
2022-01-21T09:48:13 >>> dev-libs/libical-3.0.12
2022-01-21T09:48:27 >>> dev-libs/plasma-wayland-protocols-1.6.0
2022-01-21T09:48:34 >>> dev-qt/qtwebsockets-5.15.2-r11
2022-01-21T09:48:47 >>> kde-frameworks/kwindowsystem-5.90.0-r1
2022-01-21T09:49:02 >>> kde-frameworks/kholidays-5.90.0-r1
2022-01-21T09:49:13 >>> kde-frameworks/solid-5.90.0-r1
2022-01-21T09:49:33 >>> kde-frameworks/qqc2-desktop-style-5.90.0-r1
2022-01-21T09:49:45 >>> kde-frameworks/ktexteditor-5.90.0-r1
2022-01-21T09:50:20 >>> kde-frameworks/plasma-5.90.0-r1
Comment 6 b2c 2022-01-27 17:42:48 UTC
Ok, I managed to avoid the segfault by masking the 20.x versions of xorg-server and xorg-drivers and (re)building the 1.20 versions of it. I also rebuilt the following packages, just to make sure:



xorg "use" settings:

[I] x11-base/xorg-server
     Installed versions:  1.20.14(0/1.20.14)^t(04:53:59 PM 01/27/2022)(elogind udev xnest xorg xvfb -debug -dmx -kdrive -minimal -selinux -suid -systemd -test -unwind -xcsecurity -xephyr)

[I] x11-base/xorg-drivers
     Installed versions:  1.20-r2(04:53:03 PM 01/27/2022)(INPUT_DEVICES="evdev libinput -elographics -joystick -synaptics -vmmouse -void -wacom" VIDEO_CARDS="nvidia vesa -amdgpu -ast -dummy -fbdev -freedreno -geode -glint -i915 -i965 -intel -mga -nouveau -nv -omap -qxl -r128 -radeon -radeonsi -siliconmotion -tegra -vc4 -via -virtualbox -vmware")

Not sure on how to progress from here, I'm open for suggestions :)
Comment 7 Andreas Sturmlechner gentoo-dev 2022-01-27 18:24:49 UTC
There are other reports about segfaults with recent xorg-server update.
Comment 8 Andreas Sturmlechner gentoo-dev 2022-01-27 18:27:11 UTC
*** Bug 831846 has been marked as a duplicate of this bug. ***
Comment 9 Andreas Sturmlechner gentoo-dev 2022-02-26 18:31:21 UTC
Nothing to do for kde proj then.
Comment 10 b2c 2022-03-31 20:32:40 UTC
Sorry for the late follow up, real life happened and I just now finally set up my system for debugging. I managed to get a crashdump from /usr/lib64/libexec/kf5/kscreen_backend_launcher which seems to be the binary causing the crash in the first place. Took me a while to figure that out, not used to stuff like this. 

I attached the full backtrace as text to the issue now, maybe you guys can take another look and make something of it?
Comment 11 b2c 2022-03-31 20:33:32 UTC
Created attachment 768343 [details]
backtrace from /usr/lib64/libexec/kf5/kscreen_backend_launcher
Comment 12 b2c 2022-03-31 20:39:15 UTC
PS: I updated the bug at KDE too