Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 831663 - sci-visualization/veusz-3.3.1-r1 /var/tmp/portage/sci-visualization/veusz-3.3.1-r1/temp/environment: line 3065: 124 Segmentation fault "${@}"
Summary: sci-visualization/veusz-3.3.1-r1 /var/tmp/portage/sci-visualization/veusz-3.3...
Status: UNCONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-21 06:36 UTC by Alessandro Barbieri
Modified: 2022-01-25 11:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge_info (emerge_info,36.58 KB, text/plain)
2022-01-21 06:37 UTC, Alessandro Barbieri
Details
veusz-3.3.1-r1:20220121-063413.log (veusz-3.3.1-r1:20220121-063413.log,30.44 KB, text/plain)
2022-01-21 06:37 UTC, Alessandro Barbieri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alessandro Barbieri 2022-01-21 06:36:56 UTC
This package fails to build on an unstable system. Attached relevant logs and emerge --info
Comment 1 Alessandro Barbieri 2022-01-21 06:37:02 UTC
Created attachment 762934 [details]
emerge_info

emerge --info
Comment 2 Alessandro Barbieri 2022-01-21 06:37:03 UTC
Created attachment 762935 [details]
veusz-3.3.1-r1:20220121-063413.log

build log
Comment 3 Alessandro Barbieri 2022-01-21 06:38:37 UTC
Local revbump as a fix for the sip bug
Comment 4 George Shapovalov 2022-01-25 11:55:30 UTC
I can confirm. It was originally failing during the build as described in bug #815421. After applying the patches mentioned there, it now proceeds to compile, but then segfaults as in this one, or sometimes hangs while compiling the same file as in this report, or throws longjump error as in bug #823005.

The upstream has a new 3.4 version out, with bunch of binaries built by other distros, seemingly for the updated sip/python. It may be easier to get the 3.4 version in than try to trace the issue with this one..