Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 831048 - GNOME stabilization for January 2022
Summary: GNOME stabilization for January 2022
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: CC-ARCHES
: 807897 (view as bug list)
Depends on: 831049 831050 831068
Blocks: CVE-2021-39365 831946
  Show dependency tree
 
Reported: 2022-01-12 04:59 UTC by Matt Turner
Modified: 2022-04-02 13:23 UTC (History)
1 user (show)

See Also:
Package list:
app-admin/gnome-system-log-3.9.90-r1 amd64 x86 app-arch/gnome-autoar-0.4.2 amd64 arm64 x86 app-cdr/brasero-3.12.3 amd64 ppc ppc64 x86 app-misc/tracker-miners-3.1.3 amd64 arm64 x86 app-text/enchant-2.3.2 amd64 arm arm64 ppc ppc64 sparc x86 app-text/iso-codes-4.9.0 amd64 arm arm64 ppc ppc64 sparc x86 dev-cpp/glibmm-2.66.2 amd64 arm arm64 ppc ppc64 sparc x86 dev-lang/vala-0.48.22 amd64 arm arm64 ppc ppc64 sparc x86 dev-lang/vala-0.50.10 amd64 arm arm64 ppc ppc64 sparc x86 dev-lang/vala-0.52.10 amd64 arm arm64 ppc ppc64 sparc x86 dev-libs/glib-2.70.2 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-libs/gobject-introspection-1.70.0 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-libs/gobject-introspection-common-1.70.0 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-libs/json-glib-1.6.6-r1 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-libs/jsonrpc-glib-3.40.0 amd64 x86 dev-libs/libgnome-games-support-1.8.2 amd64 x86 dev-libs/libinput-1.19.3 amd64 arm arm64 ppc ppc64 sparc x86 dev-libs/vala-common-0.52.10 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-python/pyatspi-2.38.2 amd64 arm64 sparc x86 dev-util/gdbus-codegen-2.70.2 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-util/gi-docgen-2021.8 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-util/glib-utils-2.70.2 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-util/gtk-update-icon-cache-3.24.30 amd64 arm arm64 hppa ppc ppc64 sparc x86 dev-util/umockdev-0.16.2 amd64 arm arm64 ppc ppc64 sparc x86 games-board/tali-40.4 amd64 x86 gnome-base/gnome-core-libs-40.6 amd64 x86 gnome-base/gnome-desktop-40.7 amd64 arm64 x86 gnome-base/gnome-keyring-40.0-r1 amd64 arm arm64 ppc ppc64 sparc x86 gnome-base/gnome-shell-40.5-r1 amd64 arm64 x86 gnome-extra/eiciel-0.9.13.1 amd64 x86 gui-libs/gtk-4.4.1 amd64 arm64 ppc64 x86 gui-libs/libhandy-1.4.0 amd64 arm64 ppc ppc64 x86 media-gfx/simple-scan-40.7 amd64 ppc ppc64 x86 media-libs/grilo-0.3.14 amd64 arm64 x86 media-libs/gupnp-dlna-0.12.0 amd64 x86 media-libs/harfbuzz-3.1.2 amd64 arm arm64 hppa ppc ppc64 sparc x86 media-plugins/grilo-plugins-0.3.14 amd64 arm64 x86 media-video/subtitleeditor-0.54.0_p5 amd64 x86 media-video/totem-3.38.2 amd64 x86 net-dialup/moserial-3.0.21 amd64 x86 net-libs/dleyna-renderer-0.7.2 amd64 net-libs/glib-networking-2.70.1 amd64 arm arm64 ppc ppc64 sparc x86 net-libs/gnome-online-accounts-3.40.1 amd64 arm64 x86 net-libs/gssdp-1.4.0.1 amd64 arm64 ppc64 x86 net-libs/gtk-vnc-1.3.0 amd64 x86 net-libs/gupnp-1.4.2 amd64 arm64 ppc64 x86 net-libs/gupnp-igd-1.2.0 amd64 arm64 x86 net-libs/libmbim-1.26.2 amd64 arm arm64 ppc ppc64 x86 net-libs/libsoup-2.74.2 amd64 arm arm64 ppc ppc64 sparc x86 net-misc/dleyna-server-0.7.2 amd64 x86 net-misc/gupnp-tools-0.10.2 amd64 x86 net-misc/modemmanager-1.18.4 amd64 arm arm64 ppc ppc64 x86 net-misc/rygel-0.40.3 amd64 x86 net-vpn/networkmanager-openvpn-1.8.16 amd64 x86 x11-libs/gdk-pixbuf-2.42.6-r1 amd64 arm arm64 hppa ppc ppc64 sparc x86 x11-libs/gtk+-3.24.30 amd64 arm arm64 hppa ppc ppc64 sparc x86 x11-misc/colord-1.4.5-r3 amd64 arm arm64 ppc ppc64 x86 x11-wm/mutter-40.5-r6 amd64 arm64 x86
Runtime testing required: ---
nattka: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Turner gentoo-dev 2022-01-12 04:59:54 UTC
Mostly minor version bumps, but also some core libs from GNOME 41 like glib, gjs, libsoup, and libhandy.

Please stabilize!
Comment 1 Matt Turner gentoo-dev 2022-01-12 05:00:36 UTC
Oh, and gui-libs/gtk.
Comment 2 NATTkA bot gentoo-dev 2022-01-12 05:05:50 UTC Comment hidden (obsolete)
Comment 3 NATTkA bot gentoo-dev 2022-01-12 05:57:39 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2022-01-12 06:09:40 UTC Comment hidden (obsolete)
Comment 5 Mart Raudsepp gentoo-dev 2022-01-12 07:39:06 UTC
I was about to file one as well with slightly newer versions in some cases. Let me review this today/tomorrow while arches do the dependent bug or so
Comment 6 NATTkA bot gentoo-dev 2022-01-12 07:45:40 UTC Comment hidden (obsolete)
Comment 7 NATTkA bot gentoo-dev 2022-01-12 19:49:35 UTC Comment hidden (obsolete)
Comment 8 Mart Raudsepp gentoo-dev 2022-01-15 23:29:50 UTC
I can't get through all of what I wanted as quick as I hoped, so lets just go with this now and I'll do a follow-up afterwards.

Did these changes though to package list:
* Updated vala versions to newer, should be safe with regression for shotwell taken care of in stable
* Removed gjs stabilization for now, as it's the GNOME 41 version (maybe it's fine with GNOME 40?)
Comment 9 Arthur Zamarin archtester gentoo-dev 2022-01-20 09:42:22 UTC
ppc64 done
Comment 10 Jakov Smolić archtester gentoo-dev 2022-01-20 09:58:37 UTC
x86 done
Comment 11 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-24 03:39:41 UTC
amd64 done
Comment 12 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-24 14:43:42 UTC
arm64 done
Comment 13 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-24 14:44:35 UTC
arm done
Comment 14 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-24 14:49:13 UTC
ppc done
Comment 15 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-24 19:20:55 UTC
hppa done
Comment 16 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2022-01-24 19:21:31 UTC
sparc done

all arches done
Comment 17 Andreas Sturmlechner gentoo-dev 2022-04-02 13:23:05 UTC
*** Bug 807897 has been marked as a duplicate of this bug. ***