Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 828583 (CVE-2021-4069) - <app-editors/{gvim,vim,vim-core}-8.2.3741: use after free
Summary: <app-editors/{gvim,vim,vim-core}-8.2.3741: use after free
Status: IN_PROGRESS
Alias: CVE-2021-4069
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://github.com/vim/vim/commit/e03...
Whiteboard: B3 [glsa]
Keywords:
Depends on: 829396
Blocks: CVE-2021-3968, CVE-2021-3973, CVE-2021-3974, CVE-2021-3984, CVE-2021-4019
  Show dependency tree
 
Reported: 2021-12-08 20:26 UTC by John Helmert III
Modified: 2022-08-14 05:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2021-12-08 20:26:40 UTC
CVE-2021-4069:

vim is vulnerable to Use After Free


Needs bump to 8.2.3741.
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-12-16 10:47:43 UTC
I didn't notice the wrong Bug tag!

https://github.com/gentoo/gentoo/commit/f2b69d0f2b4bf2dfbfa929e7800093b9bf84f1b6 And friends bumped this. Am on mobile though. Will update rest of bug metadata later
Comment 2 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2021-12-16 17:14:27 UTC
Please stabilize when ready.
Comment 3 John Helmert III archtester Gentoo Infrastructure gentoo-dev Security 2022-08-14 05:31:57 UTC
GLSA request filed