Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 828079 - app-admin/ansible: error "ansible 4.8.0 has requirement ansible-core<2.12,>=2.11.6, but you have ansible-core 2.12.0." is blocking PIP usage
Summary: app-admin/ansible: error "ansible 4.8.0 has requirement ansible-core<2.12,>=2...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Matthew Thode ( prometheanfire )
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-03 15:06 UTC by Thomas Deutschmann
Modified: 2021-12-03 15:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log of firefox showing the `pip check` error (build.log,25.90 KB, text/plain)
2021-12-03 15:13 UTC, Thomas Deutschmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Deutschmann gentoo-dev 2021-12-03 15:06:41 UTC
I run into an interesting www-client/firefox build issue.

www-client/firefox is creating a virtualenv. This is currently failing because PIP detects a broken depgraph:

> ansible 4.8.0 has requirement ansible-core<2.12,>=2.11.6, but you have ansible-core 2.12.0.
Comment 1 Thomas Deutschmann gentoo-dev 2021-12-03 15:13:14 UTC
Created attachment 757263 [details]
build.log of firefox showing the `pip check` error