Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 82766 - ebuild for the Torque Game Engine SDK
Summary: ebuild for the Torque Game Engine SDK
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: x86 Linux
: High enhancement (vote)
Assignee: Gentoo Games
URL: http://www.garagegames.com
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks:
 
Reported: 2005-02-20 23:17 UTC by Josh Nichols (RETIRED)
Modified: 2010-01-04 22:33 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
torque-sdk-1.3.ebuild (torque-sdk-1.3.ebuild,1.42 KB, text/plain)
2005-02-20 23:17 UTC, Josh Nichols (RETIRED)
Details
1.3-gccfixes.patch (1.3-gccfixes.patch,2.85 KB, text/plain)
2005-02-20 23:18 UTC, Josh Nichols (RETIRED)
Details
torque-sdk-1.3.ebuild (torque-sdk-1.3.ebuild,1.40 KB, text/plain)
2005-02-21 08:33 UTC, Josh Nichols (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Nichols (RETIRED) gentoo-dev 2005-02-20 23:17:17 UTC
Torque is a multiplatform game engine originally used to create Tribes 2. Noticing the lack of an ebuild for it, I decided to create one.

It is licensed under the 'Torque Game Engine SDK "Indie" License'.

A few notes/issues:
* there may be an alsa dependency. The documentation never explicitly mentions it, but lddconfig indicates that it uses an alsa library.
* building torque does not make use of the system's cflags/cxxflags. This is partly because I'm not familar enough with the build process of torque or ebuilds in general

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Josh Nichols (RETIRED) gentoo-dev 2005-02-20 23:17:52 UTC
Created attachment 51756 [details]
torque-sdk-1.3.ebuild
Comment 2 Josh Nichols (RETIRED) gentoo-dev 2005-02-20 23:18:51 UTC
Created attachment 51757 [details]
1.3-gccfixes.patch
Comment 3 Josh Nichols (RETIRED) gentoo-dev 2005-02-21 08:33:37 UTC
Created attachment 51790 [details]
torque-sdk-1.3.ebuild

I had previously made a new license, but apparently it was already in
/usr/portage/licenses as TGE.
Comment 4 Valeriy Malov 2009-12-05 14:37:22 UTC
Seems like they dropped Linux support year ago or something
Comment 5 Samuli Suominen gentoo-dev 2010-01-04 22:33:28 UTC
Verified. There's only Windows and Mac links available. Closing as CANTFIX.