Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 825402 - app-shells/pwsh-bin-7.2.6 installs files with unresolved SONAME dependencies
Summary: app-shells/pwsh-bin-7.2.6 installs files with unresolved SONAME dependencies
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Maciej Barć
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-21 07:11 UTC by Agostino Sarubbo
Modified: 2022-09-03 05:38 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,39.17 KB, text/plain)
2021-11-21 07:12 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-11-21 07:11:57 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: app-shells/pwsh-bin-7.2.0 installs files with unresolved SONAME dependencies.
Discovered on: amd64 (internal ref: ci)
Comment 1 Agostino Sarubbo gentoo-dev 2021-11-21 07:12:00 UTC
Created attachment 754074 [details]
build.log

build log and emerge --info
Comment 2 Zac Medico gentoo-dev 2021-11-21 19:07:16 UTC
The ebuild already has a dependency on dev-util/lttng-ust:0, so it looks like the tinderbox /var/db/pkg/ entry for dev-util/lttng-ust may be missing PROVIDES metadata (may have been caused by a broken scanelf as in bug 811462).

If your scanelf is working now, then a rebuild of dev-util/lttng-ust should fix its PROVIDES metadata.
Comment 3 Agostino Sarubbo gentoo-dev 2021-12-15 07:58:09 UTC
ci has reproduced this issue with version 7.2.1 - Updating summary.
Comment 4 Agostino Sarubbo gentoo-dev 2022-06-03 05:54:22 UTC
ci has reproduced this issue with version 7.2.4 - Updating summary.
Comment 5 Agostino Sarubbo gentoo-dev 2022-06-22 04:21:36 UTC
ci has reproduced this issue with version 7.2.5 - Updating summary.
Comment 6 Agostino Sarubbo gentoo-dev 2022-08-13 17:36:12 UTC
ci has reproduced this issue with version 7.2.6 - Updating summary.