Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 824970 - sci-electronics/geda-1.9.2-r1 - configure: error: you need at least version 2.0.0 of guile
Summary: sci-electronics/geda-1.9.2-r1 - configure: error: you need at least version 2...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: The Soldering-Iron Brotherhood
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: guile-3.0
  Show dependency tree
 
Reported: 2021-11-19 16:35 UTC by Toralf Förster
Modified: 2022-03-02 12:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,15.36 KB, text/plain)
2021-11-19 16:35 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,203.36 KB, text/plain)
2021-11-19 16:35 UTC, Toralf Förster
Details
environment (environment,73.12 KB, text/plain)
2021-11-19 16:35 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,26.30 KB, application/x-bzip)
2021-11-19 16:35 UTC, Toralf Förster
Details
logs.tar.bz2 (logs.tar.bz2,13.33 KB, application/x-bzip)
2021-11-19 16:35 UTC, Toralf Förster
Details
sci-electronics:geda-1.9.2-r1:20211119-082029.log (sci-electronics:geda-1.9.2-r1:20211119-082029.log,13.04 KB, text/plain)
2021-11-19 16:35 UTC, Toralf Förster
Details
temp.tar.bz2 (temp.tar.bz2,24.78 KB, application/x-bzip)
2021-11-19 16:36 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-11-19 16:35:51 UTC
checking pkg-config is at least version 0.9.0... yes
checking for GUILE... no
checking for GUILE... no
checking for GUILE... no
configure: error: you need at least version 2.0.0 of guile

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sci-electronics/geda-1.9.2-r1/work/geda-gaf-1.9.2/config.log
 * ERROR: sci-electronics/geda-1.9.2-r1::gentoo failed (configure phase):

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_desktop_plasma_systemd-j4-20211117-092326

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
clang version 13.0.0
Target: x86_64-pc-linux-gnu
Thread model: posix
InstalledDir: /usr/lib/llvm/13/bin
/usr/lib/llvm/13
13.0.0
Python 3.9.9
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby27 (with Rubygems)
  [3]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.56.1 *
The Glorious Glasgow Haskell Compilation System, version 8.10.4
php cli:

  HEAD of ::gentoo
commit ef6fd216edc52088093cc80305221fc2e4d46906
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Fri Nov 19 07:30:11 2021 +0000

    2021-11-19 07:29:50 UTC

emerge -qpvO sci-electronics/geda
[ebuild  N    ] sci-electronics/geda-1.9.2-r1  USE="nls -debug -doc -examples -stroke -threads"
Comment 1 Toralf Förster gentoo-dev 2021-11-19 16:35:52 UTC
Created attachment 753050 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-11-19 16:35:54 UTC
Created attachment 753054 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2021-11-19 16:35:55 UTC
Created attachment 753058 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2021-11-19 16:35:56 UTC
Created attachment 753062 [details]
etc.portage.tar.bz2
Comment 5 Toralf Förster gentoo-dev 2021-11-19 16:35:58 UTC
Created attachment 753066 [details]
logs.tar.bz2
Comment 6 Toralf Förster gentoo-dev 2021-11-19 16:35:59 UTC
Created attachment 753070 [details]
sci-electronics:geda-1.9.2-r1:20211119-082029.log
Comment 7 Toralf Förster gentoo-dev 2021-11-19 16:36:00 UTC
Created attachment 753074 [details]
temp.tar.bz2
Comment 8 Thomas Beierlein gentoo-dev 2021-12-28 17:14:11 UTC
I asked upstream bout the problem. They try to drop dependency for Guile for next release.

There is a fork of geda named "Lepton EDA"  which has some migration done to Guile-3. I will try to port there solution back to geda package in next days.
Comment 9 Larry the Git Cow gentoo-dev 2022-03-02 12:35:01 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=dbf9debbe4c86a5b84f0342147d554fde250d264

commit dbf9debbe4c86a5b84f0342147d554fde250d264
Author:     Andrew Ammerlaan <andrewammerlaan@gentoo.org>
AuthorDate: 2022-03-02 12:34:19 +0000
Commit:     Andrew Ammerlaan <andrewammerlaan@gentoo.org>
CommitDate: 2022-03-02 12:34:54 +0000

    sci-electronics/geda: add version 1.10.2
    
    Closes: https://bugs.gentoo.org/701898
    Bug: https://bugs.gentoo.org/824970
    Bug: https://bugs.gentoo.org/643822
    Bug: https://bugs.gentoo.org/681768
    Bug: https://bugs.gentoo.org/717436
    Bug: https://bugs.gentoo.org/779808
    Bug: https://bugs.gentoo.org/704768
    Bug: https://bugs.gentoo.org/642464
    Package-Manager: Portage-3.0.30, Repoman-3.0.3
    Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>

 sci-electronics/geda/Manifest           |  1 +
 sci-electronics/geda/geda-1.10.2.ebuild | 89 +++++++++++++++++++++++++++++++++
 2 files changed, 90 insertions(+)