Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 823774 - media-libs/mesa-21.2.5 has a failing test: mesa:util / u_debug_stack
Summary: media-libs/mesa-21.2.5 has a failing test: mesa:util / u_debug_stack
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Gentoo X packagers
: 927358 (view as bug list)
Depends on:
Reported: 2021-11-14 21:47 UTC by Kevin Lyles
Modified: 2024-04-05 22:33 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

emerge --info (file_823774.txt,6.92 KB, text/plain)
2021-11-14 21:47 UTC, Kevin Lyles
build.log (build.log.bz2,146.07 KB, application/x-bzip)
2021-11-14 21:48 UTC, Kevin Lyles
testlog.txt from mesa-22.0.3 (testlog.txt,494.76 KB, text/plain)
2022-05-08 19:16 UTC, Jonathan Lovelace

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Lyles 2021-11-14 21:47:40 UTC
Created attachment 751172 [details]
emerge --info

Emerging media-libs/mesa-21.2.5 with FEATURES=test results in a failing unit test
Comment 1 Kevin Lyles 2021-11-14 21:48:50 UTC
Created attachment 751174 [details]
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-15 01:15:44 UTC
I think we'd need another log:

Full log written to /var/tmp/portage/media-libs/mesa-21.2.5/work/mesa-21.2.5-abi_x86_32.x86/meson-logs/testlog.txt
 * ERROR: media-libs/mesa-21.2.5::gentoo failed (test phase):
Comment 3 Jonathan Lovelace 2022-05-08 19:16:14 UTC
Created attachment 777623 [details]
testlog.txt from mesa-22.0.3

I hit this test failure in 22.0.3 today; here's the testlog.txt from that run. 

(From the top of my emerge build.log, USE="X abi_x86_32 abi_x86_64 amd64 cpu_flags_x86_sse2 elibc_glibc gles1 gles2 kernel_linux llvm lm-sensors test userland_GNU video_cards_intel xvmc zstd" and FEATURES="distcc fakeroot network-sandbox preserve-libs sandbox test userpriv usersandbox".)
Comment 4 Jonathan Lovelace 2022-07-27 23:57:10 UTC
Just to make clear that this is still present in versions currently in the tree, I again saw this in version 22.1.3. 

Of the two upstream issues added as "See Also" links, looks like it's the same issue. And, prompted by the discussion there, I tried building version 22.1.2 with only ABI_X86="64", and it passed its tests. So it looks like this test only fails on ABI_X86=32.
Comment 5 Jonathan Lovelace 2022-09-26 03:03:42 UTC
And this (or some other failure of the same test in the same ABI) is still present in 22.1.7.
Comment 6 Matt Turner gentoo-dev 2023-09-29 02:56:59 UTC
Still present in 23.2.1.
Comment 7 Matt Turner gentoo-dev 2023-09-29 03:50:48 UTC
Test seems to pass when built with -O0.
Comment 8 Matt Turner gentoo-dev 2024-03-29 20:17:53 UTC
*** Bug 927358 has been marked as a duplicate of this bug. ***
Comment 9 Matt Turner gentoo-dev 2024-03-29 21:04:35 UTC
(In reply to Matt Turner from comment #7)
> Test seems to pass when built with -O0.

Test seems to pass when built with -O1 -fno-omit-frame-pointer.
Comment 10 Jonathan Lovelace 2024-04-05 22:33:47 UTC
I still get the same test failure in version 24.0.4 with CFLAGS="-O1 -fno-omit-frame-pointer". What USE flags are set when you see tests passing? (In particular, I wonder if you're building for the 32-bit ABI, since there's at least one package where I only encounter test failures when building for the 32-bit ABI as well as the 64-bit.)