Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 82081 - x11-libs/openmotif: X11/Xmu/Editres.h header present but cannot be compiled
Summary: x11-libs/openmotif: X11/Xmu/Editres.h header present but cannot be compiled
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Ulrich Müller
: 82084 257612 257614 (view as bug list)
Depends on:
Blocks: autoconf-2.64
  Show dependency tree
Reported: 2005-02-15 00:51 UTC by Ioan Marius Curelariu
Modified: 2009-02-04 21:55 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

openmotif-2.3.1-ac-editres.patch (openmotif-2.3.1-ac-editres.patch,358 bytes, patch)
2009-02-04 19:22 UTC, Ulrich Müller
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ioan Marius Curelariu 2005-02-15 00:51:00 UTC
When I tried to emerge openmotif 2.2.3, I was able to see in the configure step an warning from autoconf that X11/Xmu/Editres.h is present but cannot be compiled.
Autoconf checks for the existence of this file with:
AC_CHECK_HEADERS(X11/Xmu/Editres.h. ...

Reproducible: Always
Steps to Reproduce:
1. Emerge xorg-x11 6.8.2
2. Try to emerge openmotif 2.2.3

Actual Results:  
As a result, the will not link agains

I think this problem can be solved in two ways:
1. Someone to write a specialized M4 macro in autoconf to check the existnce of
Editres.h file (I'm not so experienced with M4 macros, so I can't write it
myself :( )
2. Inside the Editres.h file, put an include to X11/Xmu/Xmu.h.
Comment 1 Heinrich Wendel (RETIRED) gentoo-dev 2005-02-15 06:04:19 UTC
spyderous: any idea? bug 82084 seems related
Comment 2 Roland Bär 2005-02-15 08:25:55 UTC
Got following here on amd64:
checking for IceConnectionNumber in -lICE... yes
checking whether libXt was compiled with -DXTHREADS... yes
checking X11/Xmu/Editres.h usability... no
checking X11/Xmu/Editres.h presence... yes
configure: WARNING: X11/Xmu/Editres.h: present but cannot be compiled
configure: WARNING: X11/Xmu/Editres.h:     check for missing prerequisite headers?
configure: WARNING: X11/Xmu/Editres.h: see the Autoconf documentation
configure: WARNING: X11/Xmu/Editres.h:     section "Present But Cannot Be Compiled"
configure: WARNING: X11/Xmu/Editres.h: proceeding with the preprocessor's resultconfigure: WARNING: X11/Xmu/Editres.h: in the future, the compiler will take precedence
configure: WARNING:     ## ------------------------------------------ ##
configure: WARNING:     ## Report this to the AC_PACKAGE_NAME lists.  ##
configure: WARNING:     ## ------------------------------------------ ##
checking for X11/Xmu/Editres.h... yes
Maybe this gives a hit.
emerge was then succesful here...
Comment 3 Donnie Berkholz (RETIRED) gentoo-dev 2005-02-15 14:05:57 UTC
No ideas offhand. Maybe I can do some searching around later.

Perhaps reporter could paste config.log
Comment 4 Ioan Marius Curelariu 2005-02-16 00:46:12 UTC
Same happens on x86 as in comment# 2 (for amd64).
Finnaly, openmotif does compile, but does not append the "-lXmu" to "dependency_libs" in
At the first, I tought that this causes nedit fail to link, but then I found out that nedit does not use libtool anyway, so I had to explicitely add -lXmu to its library list in Makefile.linux (of nedit) and solved my original problem.
Anyway, as I told, to fix this in openmotif I made a modification in X11/Xmu/Editres.h file, including the X11/Xmu/Xmu.h somewhere at the begining of the file. That made it compile and autoconf did not complain anymore.
But I do not think this is the right way to fix it! I do think that a more appropriate approach would be to write a special M4 macro for autoconf that checks the existence and usability of Editres.h file. Unfortunately I do not know good enough M4 language to write it myself :(
Comment 5 Heinrich Wendel (RETIRED) gentoo-dev 2005-03-02 02:44:13 UTC
*** Bug 82084 has been marked as a duplicate of this bug. ***
Comment 6 Heinrich Wendel (RETIRED) gentoo-dev 2005-03-25 03:43:29 UTC
still a problem?
Comment 7 Heinrich Wendel (RETIRED) gentoo-dev 2005-04-13 11:06:25 UTC
still a problem?
Comment 8 Roland Bär 2005-04-13 23:50:08 UTC
The warnings in comment 2 are still in opnemotif-2.2.3-r3
Otherwise it emerges fine, as before ...
Comment 9 Ulrich Müller gentoo-dev 2009-02-04 18:59:36 UTC
*** Bug 257612 has been marked as a duplicate of this bug. ***
Comment 10 Ulrich Müller gentoo-dev 2009-02-04 19:01:16 UTC
Comment 11 Ulrich Müller gentoo-dev 2009-02-04 19:22:56 UTC
Created attachment 180953 [details, diff]

Diego, does attached patch fix the issue for you?
Comment 12 Diego Elio Pettenò (RETIRED) gentoo-dev 2009-02-04 19:25:19 UTC
I cannot test it right now but I'd expect it to.
Comment 13 Ulrich Müller gentoo-dev 2009-02-04 21:51:09 UTC
(In reply to comment #12)
> I cannot test it right now but I'd expect it to.

Fixed in CVS and reported upstream:

Thanks to everybody, and apologies that it took us four years to fix this bug.
Comment 14 Ulrich Müller gentoo-dev 2009-02-04 21:55:00 UTC
*** Bug 257614 has been marked as a duplicate of this bug. ***