Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 820527 - dev-util/codeblocks-20.03-r2 with contrib x32 failed to emerge (wxSmith)
Summary: dev-util/codeblocks-20.03-r2 with contrib x32 failed to emerge (wxSmith)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Normal normal (vote)
Assignee: Sergey Torokhov
URL:
Whiteboard:
Keywords: PullRequest
Depends on:
Blocks:
 
Reported: 2021-10-27 15:21 UTC by sevilla.larry
Modified: 2021-11-02 11:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
CodeBlocks with contrib log files (codeblocks.tar.gz,45.26 KB, text/plain)
2021-10-28 05:50 UTC, sevilla.larry
Details
dev-util/codeblocks: Specify Boost libdir (codeblocks-20.03-r2.ebuild-boost-libdir.patch,296 bytes, patch)
2021-10-28 08:28 UTC, Tee KOBAYASHI
Details | Diff
codeblocks-20.03-r4.ebuild (codeblocks-20.03-r4.ebuild,1.84 KB, text/plain)
2021-10-29 18:41 UTC, Sergey Torokhov
Details
emerge with codeblocks-20.03-r4.ebuild (codeblocks-20.03-r4.tar.gz,26.11 KB, application/gzip)
2021-10-30 10:59 UTC, sevilla.larry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sevilla.larry 2021-10-27 15:21:32 UTC
CodeBlocks with contrib x64 emerged successfully
but
CodeBlocks with contrib x32 FAILED to emerged
CodeBlocks without contrib x32 emerge successfully, but does NOT contain wxSmith



Reproducible: Always

Steps to Reproduce:
1.edit /etc/portage/package.use/codeblocks
  dev-util/codeblocks contrib
2.emerge -j codeblocks
3.
Actual Results:  
CodeBlocks failed to emerge/install

Expected Results:  
CodeBlocks is emerged/installed

emerge --info https://pastebin.com/ip2svJRK

config.log https://pastebin.com/qUysyKJv

build.log https://pastebin.com/PL1kZTwA

ebuild environment http://controlc.com/2a60d6d0
Comment 1 Sam James archtester gentoo-dev Security 2021-10-27 15:22:40 UTC
Could you attach the logs instead please? Compressed if needed.
Comment 2 sevilla.larry 2021-10-27 18:45:03 UTC
emerge -j codeblocks > emerge.log https://pastebin.com/76bYJC6i

not sure if this is what you mean.
Comment 3 sevilla.larry 2021-10-28 05:50:35 UTC
Created attachment 747021 [details]
CodeBlocks with contrib log files
Comment 4 Sam James archtester gentoo-dev Security 2021-10-28 06:06:56 UTC
(In reply to sevilla.larry from comment #2)
> emerge -j codeblocks > emerge.log https://pastebin.com/76bYJC6i
> 
> not sure if this is what you mean.

I meant don't use an external site, attach it as a file to bugzilla (uplod it)
Comment 5 Tee KOBAYASHI 2021-10-28 08:28:10 UTC
Created attachment 747024 [details, diff]
dev-util/codeblocks: Specify Boost libdir

Seems like we need to specify --with-boost-libdir=PATH explicitly.
Comment 6 Sergey Torokhov 2021-10-29 18:39:33 UTC
(In reply to Tee KOBAYASHI from comment #5)
> Created attachment 747024 [details, diff] [details, diff]
> dev-util/codeblocks: Specify Boost libdir
> 
> Seems like we need to specify --with-boost-libdir=PATH explicitly.

Thank you for patch! 

The error about boost version seems caused by that is described in "BUILD" info file of codeblocks tarball:

> If the NassiShneiderman-plugin should be build, you might see this error, 
> when you run configure:
> 
> checking whether the Boost::System library is available... yes
> configure: error: Could not find a version of the library!
> 
> If this happens, you have to explicitly set the boost-libdir.
> You should try to add "--with-boost-libdir=LIB_DIR" to the configure-line.
> Depending on your system, LIB_DIR might be "/usr/lib" or "/usr/lib64".
Comment 7 Sergey Torokhov 2021-10-29 18:41:35 UTC
Created attachment 747288 [details]
codeblocks-20.03-r4.ebuild

sevilla.larry 

Could you please check the build process with "codeblocks-20.03-r4.ebuild"?
Comment 8 sevilla.larry 2021-10-30 10:59:33 UTC
Created attachment 747492 [details]
emerge with codeblocks-20.03-r4.ebuild

Not so much familiar with ebuilds, but I followed these guides based on a previous problem:
https://wiki.gentoo.org/wiki/Custom_ebuild_repository
https://wiki.gentoo.org/wiki/Handbook:AMD64/Portage/CustomTree#Defining_a_custom_ebuild_repository

the ebuild was masked: ~x86, so I add:
/etc/portage/package.accept_keywords/codeblocks
=dev-util/codeblocks-20.03-r4 ~x86

emerge -j codeblocks

and failed.  attached log files.
Comment 9 Sergey Torokhov 2021-10-30 11:27:46 UTC
Please copy "files" directory from portage tree dev-util/codeblocks/ (reproduce folder structure) to your local repo dev-util/codeblocks. You forgot to do it.
Comment 10 Sergey Torokhov 2021-10-30 11:33:28 UTC
Your local repo then should contain at least:

dev-util/codeblocks/codeblocks-20.03-r4.ebuild
dev-util/codeblocks/Manifest
dev-util/codeblocks/files/*

"Manifest" file and "files" folder just copy from portage tree.
Comment 11 sevilla.larry 2021-10-30 12:12:14 UTC
(In reply to Sergey Torokhov from comment #10)
> Your local repo then should contain at least:
> 
> dev-util/codeblocks/codeblocks-20.03-r4.ebuild
> dev-util/codeblocks/Manifest
> dev-util/codeblocks/files/*
> 
> "Manifest" file and "files" folder just copy from portage tree.

Emerge completed.  wxSmith now included.  thx...
Comment 12 Sergey Torokhov 2021-10-30 12:36:59 UTC
(In reply to sevilla.larry from comment #11)

> Emerge completed.  wxSmith now included.  thx...

Thank you for feedback. I will create pull request with new fix-revision.
Comment 13 Larry the Git Cow gentoo-dev 2021-11-02 11:00:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=701ccd19940c2feb049c9364fcce163368b69cc8

commit 701ccd19940c2feb049c9364fcce163368b69cc8
Author:     Sergey Torokhov <torokhov-s-a@yandex.ru>
AuthorDate: 2021-10-30 13:10:03 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-11-02 11:00:08 +0000

    dev-util/codeblocks: Fix x32 contrib plugins. Add boost-libdir option
    
    Closes: https://bugs.gentoo.org/820527
    
    Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru>
    Closes: https://github.com/gentoo/gentoo/pull/22763
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-util/codeblocks/codeblocks-20.03-r4.ebuild | 77 ++++++++++++++++++++++++++
 1 file changed, 77 insertions(+)