Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 816288 - Re-add pybootchartgui to app-benchmarks/bootchart2 (using dev-python/pycairo)
Summary: Re-add pybootchartgui to app-benchmarks/bootchart2 (using dev-python/pycairo)
Status: RESOLVED DUPLICATE of bug 808701
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-04 20:50 UTC by Carlos
Modified: 2021-10-04 21:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos 2021-10-04 20:50:41 UTC
The `pybootchartgui` script has been removed from the app-benchmarks/bootchart2 package due to a dependency on pygtk and Python 2, from what I could understand from the Git logs.

However, most functionality is still available without pygtk by using dev-python/pycairo and Python 3. The only missing feature seems to be the interactive mode, but the only downside of it is the need of an external tool to view the generated png/pdf.

Forgive me if I'm overlooking some other reason this script was dropped that stills makes it inelegible for inclusion.
Comment 1 Conrad Kostecki gentoo-dev 2021-10-04 21:27:48 UTC

*** This bug has been marked as a duplicate of bug 808701 ***