Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 815700 - dev-libs/isl-0.24-r2: stabilisation (was: dev-libs/isl-0.24 does not respect CFLAGS)
Summary: dev-libs/isl-0.24-r2: stabilisation (was: dev-libs/isl-0.24 does not respect ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords: CC-ARCHES
Depends on:
Blocks: cflags
  Show dependency tree
 
Reported: 2021-10-01 19:09 UTC by Agostino Sarubbo
Modified: 2021-10-29 18:32 UTC (History)
1 user (show)

See Also:
Package list:
dev-libs/isl-0.24-r2
Runtime testing required: ---
nattka: sanity-check+


Attachments
build.log (build.log,142.09 KB, text/plain)
2021-10-01 19:09 UTC, Agostino Sarubbo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-10-01 19:09:17 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: dev-libs/isl-0.24 does not respect CFLAGS.
Discovered on: amd64 (internal ref: tinderbox)

NOTE:
To reproduce this issue you may want to add "-frecord-gcc-switches" to CFLAGS/CXXFLAGS/FFLAGS/FCFLAGS. If this is not something about c/c++ context see this bug as an hint to hide the QA warning (with QA_FLAGS_IGNORED) where is not possible to respect CFLAGS.
Comment 1 Agostino Sarubbo gentoo-dev 2021-10-01 19:09:20 UTC
Created attachment 742422 [details]
build.log

build log and emerge --info
Comment 2 Anthony Basile gentoo-dev 2021-10-02 17:34:10 UTC
I have no idea how you hit this, but CFLAGS is respected.  You can try, for example:

CFLAGS=-O1 ebuild isl-0.24.ebuild clean install

or CFLAGS=-O0 and look in build.log, build-abi_x86_32.x86.log, or build-abi_x86_64.amd64.log.

I don't know how the QA script is finding this, but it is a false positive.  Maybe it has something to do with the fact that isl's build system uses CFLAGS_FOR_BUILD to pick up CFLAGS for the build, but the ebuild handles that correctly.  (Incidentally the build system introduces this extra env var for cross compiling, so it does make sense.)

Anyhow, I'm closing this as invalid.  If you feel I'm wrong about this, please reopen, but I'm going to need better quality information on how this is being hit, because I can't reproduce it.
Comment 3 Agostino Sarubbo gentoo-dev 2021-10-02 18:03:17 UTC
(In reply to Anthony Basile from comment #2)
> I have no idea how you hit this, but CFLAGS is respected.  You can try, for
> example:
> 
> CFLAGS=-O1 ebuild isl-0.24.ebuild clean install
> 
> or CFLAGS=-O0 and look in build.log, build-abi_x86_32.x86.log, or
> build-abi_x86_64.amd64.log.
> 
> I don't know how the QA script is finding this, but it is a false positive. 
> Maybe it has something to do with the fact that isl's build system uses
> CFLAGS_FOR_BUILD to pick up CFLAGS for the build, but the ebuild handles
> that correctly.  (Incidentally the build system introduces this extra env
> var for cross compiling, so it does make sense.)
> 
> Anyhow, I'm closing this as invalid.  If you feel I'm wrong about this,
> please reopen, but I'm going to need better quality information on how this
> is being hit, because I can't reproduce it.

I just looked at build log and I don't find my cflags in several lines, one for example:

x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H   -I. -I/var/tmp/portage/dev-libs/isl-0.24/work/isl-0.24 -I/var/tmp/portage/dev-libs/isl-0.24/work/isl-0.24/include -Iinclude/    -O3 -fomit-frame-pointer -malign-double -fstrict-aliasing -ffast-math -c -o isl_test.o /var/tmp/portage/dev-libs/isl-0.24/work/isl-0.24/isl_test.c


my CFLAGS are:
CFLAGS="-O2 -pipe -march=x86-64 -frecord-gcc-switches -fno-diagnostics-color"
Comment 4 Sam James archtester gentoo-dev Security 2021-10-10 22:34:35 UTC
I definitely see this here.
Comment 5 Larry the Git Cow gentoo-dev 2021-10-10 23:02:58 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=d19a7f9d9ba8362f9e12a28805957bf17c0b6cb2

commit d19a7f9d9ba8362f9e12a28805957bf17c0b6cb2
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-10-10 22:57:25 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-10-10 22:57:25 +0000

    dev-libs/isl: respect CFLAGS
    
    Drop the fun (and aggressive) AX_CC_MAXOPT macro call
    which was causing us to not respect the user's CFLAGS.
    
    Note that 0.24 seemed to be triggering maintainer mode;
    have chucked eautoreconf into the ebuild for 0.24-r1
    given it seemingly wasn't doing any harm to be doing
    it informally in 0.24 anyway, but will keep an eye on
    it.
    
    Revbump because of the aforementioned churn in a
    critical dependency.
    
    Bug: https://bugs.gentoo.org/815700
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-libs/isl/files/isl-0.24-gdb-autoload-dir.patch | 35 ++++++++++
 dev-libs/isl/files/isl-0.24-respect-flags.patch    | 14 ++++
 dev-libs/isl/isl-0.24-r1.ebuild                    | 80 ++++++++++++++++++++++
 dev-libs/isl/isl-0.24.ebuild                       |  6 +-
 4 files changed, 133 insertions(+), 2 deletions(-)
Comment 6 Sam James archtester gentoo-dev Security 2021-10-10 23:11:21 UTC
Let's give it a bit of time first.
Comment 7 Rolf Eike Beer archtester 2021-10-26 15:17:24 UTC
sparc done
Comment 8 Agostino Sarubbo gentoo-dev 2021-10-27 06:36:01 UTC
amd64 stable
Comment 9 Agostino Sarubbo gentoo-dev 2021-10-27 06:37:18 UTC
x86 stable
Comment 10 Sam James archtester gentoo-dev Security 2021-10-28 14:56:35 UTC
arm done
Comment 11 Sam James archtester gentoo-dev Security 2021-10-28 14:56:36 UTC
arm64 done
Comment 12 Sam James archtester gentoo-dev Security 2021-10-29 12:33:54 UTC
ppc done
Comment 13 Sam James archtester gentoo-dev Security 2021-10-29 18:32:17 UTC
ppc64 done

all arches done