Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 81461 - Skencil 0.6.16 can't start, "No module named Tkinter"
Summary: Skencil 0.6.16 can't start, "No module named Tkinter"
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Hanno Böck
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-02-10 00:27 UTC by Aldo "xoen" Giambelluca
Modified: 2005-09-09 20:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aldo "xoen" Giambelluca 2005-02-10 00:27:45 UTC
I've emerged Skencil 0.6.16, I've tryed to start it, but can't run...

Reproducible: Always
Steps to Reproduce:
1. $ skencil
Actual Results:  
Traceback (most recent call last):
  File "/usr/bin/sketch", line 34, in ?
    Sketch.main.main()
  File "/usr/lib/skencil-0.6.16/Sketch/Base/main.py", line 142, in main
    Sketch.init_ui()
  File "/usr/lib/skencil-0.6.16/Sketch/__init__.py", line 187, in init_ui
    __import__(name)
  File "/usr/lib/skencil-0.6.16/Script/export_raster.py", line 46, in ?
    from Sketch.UI.sketchdlg import SKModal
  File "/usr/lib/skencil-0.6.16/Sketch/UI/sketchdlg.py", line 66, in ?
    from Tkinter import Toplevel, IntVar, Frame, Checkbutton, Label
ImportError: No module named Tkinter


# emerge info

Portage 2.0.51-r15 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1
, 2.6.10-gentoo-r6 i686)
=================================================================
System uname: 2.6.10-gentoo-r6 i686 AMD Athlon(TM) XP 2000+
Gentoo Base System version 1.4.16
Python:              dev-lang/python-2.3.4-r1 [2.3.4 (#1, Feb  8 2005, 16:30:46)
]
dev-lang/python:     2.3.4-r1
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.4
sys-devel/binutils:  2.15.92.0.2-r1
sys-devel/libtool:   1.5.10-r4
virtual/os-headers:  2.6.8.1-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=athlon-xp -march=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/lib/X1
1/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -mcpu=athlon-xp -march=athlon-xp -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://darkstar.ist.utl.pt/gentoo"
LANG="it_IT.utf8"
LC_ALL="it_IT.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowex X aac aalib acpi alsa apm audiofile avi bash-completion b
erkdb bitmap-fonts bonobo cdparanoia cdr cjk crypt cups directfb divx4linux doc 
dts dvd dvdr dvdread encode examples exif f77 fam fbcon ffmpeg flac flash font-s
erver foomaticdb fortran gdbm gif gimpprint gnome gphoto2 gpm gstreamer gtk gtk2
 gtkhtml guile hal imagemagick imlib ipv6 jabber java javascript jpeg libcaca li
bg++ libwww lm_sensors mad matroska mikmod mime ming mmx mmx2 mng motif mp3 mpeg
 ncurses network nls nvidia ogg oggvorbis opengl oss pam pdflib perl png python 
quicktime readline real rtc sdl spell sse sse2 ssl svg svga tcltk tcpd tga tiff 
truetype truetype-fonts type1-fonts unicode usb vcd videos wmf xml xml2 xmms xpm
 xprint xv xvid zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LDFLAGS, PORTDIR_OVERLAY
Comment 1 Aldo "xoen" Giambelluca 2005-02-11 03:19:34 UTC
Problem solved...after an :
#emerge --deep --update --newuse world
...
Also portage updated (2.3.4-r1), but I think the problem is the tcltk use flag...
Comment 2 Aldo "xoen" Giambelluca 2005-02-11 03:36:01 UTC
I've tryed this :
#USE="-tclt" emerge --newuse world
Python is recompiled...
...now skencil not start with the same error before...
...so the solution is:

#USE="tcltk" emerge python


PS: My firt bug fixed ;)
Comment 3 Hanno Böck gentoo-dev 2005-02-13 11:21:48 UTC
Skencil needs python built with tcltk, as we have no possibility to depend on specific package/useflag-combinations, I can't do anything about this at the moment.

*** This bug has been marked as a duplicate of 2272 ***
Comment 4 Ed Catmur 2005-09-09 20:45:42 UTC
For now, couldn't we put a built_with_use check in pkg_setup()?
Comment 5 Ed Catmur 2005-09-09 20:47:15 UTC
forget that, see bug 103217.