Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 812923 - app-office/libreoffice-7.1.6.2: sqlbison.cxx:138:77: error: ‘yyn’ was not declared in this scope; did you mean ‘yyk’?
Summary: app-office/libreoffice-7.1.6.2: sqlbison.cxx:138:77: error: ‘yyn’ was not dec...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Office Team
URL: https://lists.freedesktop.org/archive...
Whiteboard:
Keywords:
: 812947 (view as bug list)
Depends on: 809131
Blocks: bison-3.8
  Show dependency tree
 
Reported: 2021-09-13 07:39 UTC by Kobboi
Modified: 2021-09-15 11:48 UTC (History)
23 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,373.17 KB, application/gzip)
2021-09-13 07:52 UTC, Kobboi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kobboi 2021-09-13 07:39:55 UTC
[CXX] connectivity/source/commontools/TIndexes.cxx
S=/var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2 && I=$S/instdir && W=$S/workdir &&  mkdir -p $W/CxxObject/connectivity/source/commontools/ $W/Dep/CxxObject/connectivity/source/commontools/ && cd /var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2 &&   	  x86_64-pc-linux-gnu-g++ -DBOOST_ERROR_CODE_HEADER_ONLY -DBOOST_SYSTEM_NO_DEPRECATED -DCPPU_ENV=gcc3 -DLINUX -DNDEBUG -DOSL_DEBUG_LEVEL=0 -DUNIX -DUNX -DX86_64 -D_PTHREADS -D_REENTRANT  -DOOO_DLLIMPLEMENTATION_DBTOOLS   -fvisibility=hidden  -Wno-stringop-overflow   -Wall -Wno-missing-braces -Wnon-virtual-dtor -Wendif-labels -Wextra -Wundef -Wunreachable-code -Wunused-macros  -finput-charset=UTF-8 -fmessage-length=0 -fno-common -pipe -fstack-protector-strong -fdiagnostics-color=always  -Wdeprecated-copy-dtor -Wduplicated-cond -Wlogical-op -Wshift-overflow=2 -Wunused-const-variable=1 -Wno-cast-function-type -fvisibility-inlines-hidden -fPIC -Wshadow -Woverloaded-virtual -std=c++17 -pthread  -O2 -march=znver3 -pipe -g -ggdb  -DEXCEPTIONS_ON -fexceptions -fno-enforce-eh-specs    -DLIBO_INTERNAL_ONLY  -c $S/connectivity/source/commontools/TIndexes.cxx -o $W/CxxObject/connectivity/source/commontools/TIndexes.o  -I$S/include   -I$S/config_host  -I$S/connectivity/inc -I$S/connectivity/source/inc  -I/usr/include  -I$W/UnoApiHeadersTarget/udkapi/normal -I$W/UnoApiHeadersTarget/offapi/normal -I$W/YaccTarget/connectivity/source/parse/   
[CXX] connectivity/source/commontools/TKey.cxx
/var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2/workdir/YaccTarget/connectivity/source/parse/sqlbison.cxx: In function ‘YYRESULTTAG yyuserAction(yyRuleNum, int, yyGLRStackItem*, yyGLRStack*, long int, YYSTYPE*)’:
/var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2/workdir/YaccTarget/connectivity/source/parse/sqlbison.cxx:138:77: error: ‘yyn’ was not declared in this scope; did you mean ‘yyk’?
  138 | #define SQL_NEW_RULE                    newNode("", SQLNodeType::Rule, yyr1[yyn])
      |                                                                             ^~~
/var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2/workdir/YaccTarget/connectivity/source/parse/sqlbison.cxx:5484:42: note: in expansion of macro ‘SQL_NEW_RULE’
 5484 |                 ((*yyvalp).pParseNode) = SQL_NEW_RULE;
      |                                          ^~~~~~~~~~~~
/var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2/workdir/YaccTarget/connectivity/source/parse/sqlbison.cxx:138:77: error: ‘yyn’ was not declared in this scope; did you mean ‘yyk’?
  138 | #define SQL_NEW_RULE                    newNode("", SQLNodeType::Rule, yyr1[yyn])
      |                                                                             ^~~
/var/tmp/portage/app-office/libreoffice-7.1.6.2/work/libreoffice-7.1.6.2/workdir/YaccTarget/connectivity/source/parse/sqlbison.cxx:5490:43: note: in expansion of macro ‘SQL_NEW_RULE’
 5490 |                 {((*yyvalp).pParseNode) = SQL_NEW_RULE;
      |                                           ^~~~~~~~~~~~


Reproducible: Always
Comment 1 Kobboi 2021-09-13 07:41:04 UTC
Portage 3.0.23 (python 3.9.7-final-0, !../../var/db/repos/kobboi-linux/profiles/kobboi/tanagra, gcc-11.2.0, glibc-2.33-r7, 5.13.16-gentoo-dist x86_64)
=================================================================
System uname: Linux-5.13.16-gentoo-dist-x86_64-AMD_Ryzen_9_5950X_16-Core_Processor-with-glibc2.33
KiB Mem:   131861692 total, 109739716 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Mon, 13 Sep 2021 07:00:01 +0000
Head commit of repository gentoo: 8b62b492f34a9e2905ff8ee628d01fea8dc158cd
Timestamp of repository brother-overlay: Wed, 08 Sep 2021 12:51:36 +0000
Head commit of repository brother-overlay: 38235bc4478ea4898dc365bca63db0b4ad175eb4

Head commit of repository kobboi-linux: 81a82fa9f3f789fb44061c57d7a3af091f120a2e

Timestamp of repository steam-overlay: Wed, 08 Sep 2021 12:51:32 +0000
Head commit of repository steam-overlay: b8f5a2ad298aedc39aa808f5e9ee5f70ec86cd70

sh bash 5.1_p8
ld GNU ld (Gentoo 2.37_p1 p0) 2.37
distcc 3.4 x86_64-pc-linux-gnu [disabled]
ccache version 4.4.1 [disabled]
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0-r2::gentoo
dev-lang/python:          2.7.18_p13::gentoo, 3.9.7::gentoo, 3.10.0_rc2::gentoo
dev-lang/rust:            1.54.0::gentoo
dev-util/ccache:          4.4.1::gentoo
dev-util/cmake:           3.21.2::gentoo
sys-apps/baselayout:      2.7-r3::gentoo
sys-apps/sandbox:         2.25::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.71-r1::gentoo
sys-devel/automake:       1.16.4::gentoo
sys-devel/binutils:       2.37_p1::gentoo
sys-devel/gcc:            11.2.0::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.14::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r7::gentoo
Repositories:

gentoo
    location: /var/db/repos/gentoo
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000
    sync-rsync-verify-jobs: 1
    sync-rsync-extra-opts: 
    sync-rsync-verify-max-age: 24
    sync-rsync-verify-metamanifest: yes

brother-overlay
    location: /var/db/repos/brother-overlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/brother-overlay.git
    masters: gentoo

kobboi-linux
    location: /var/db/repos/kobboi-linux
    sync-type: git
    sync-uri: https://github.com/kobboi/kobboi-linux
    masters: gentoo

steam-overlay
    location: /var/db/repos/steam-overlay
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/steam-overlay.git
    masters: gentoo

Installed sets: @kobboi-all-packages, @kobboi-machine-tanagra
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=znver3 -pipe -g -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib/modules /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.8/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.4/ext-active/ /etc/php/apache2-php8.0/ext-active/ /etc/php/cgi-php7.4/ext-active/ /etc/php/cgi-php8.0/ext-active/ /etc/php/cli-php7.4/ext-active/ /etc/php/cli-php8.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=znver3 -pipe -g -ggdb"
DISTDIR="/var/cache/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -march=znver3 -pipe -g -ggdb"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs buildpkg compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles installsources ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-install pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -march=znver3 -pipe -g -ggdb"
GENTOO_MIRRORS="ftp://kobboi-linux:*password*@10.8.0.1/2020.11"
INSTALL_MASK="/usr/src/debug /usr/lib/debug"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/var/cache/binpkgs"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl acpi alsa amd64 avahi bluetooth bzip2 cairo cdda cdr cli colord crypt cups dbus dist-kernel djvu dri dts dvd dvdr eds egl emboss encode evo exif facedetect ffmpeg flac fluidsynth fortran frei0r gdbm gif glade gles gles2 gnome gnome-keyring gnome-online-accounts gpm gstreamer gtk gtk3 gtkstyle gui iconv icu introspection ipv6 jpeg ladspa lcms libass libglvnd libnotify libsecret libtirpc lv2 lz4 lzma lzo mad midi mng modemmanager mono mp3 mp4 mpeg mtp multilib nautilus ncurses networkmanager nls nptl ogg opencv opengl openmp opus pam pango pcre pdf png policykit ppds pulseaudio qt5 readline samba screencast sdl seccomp smartcard smp spell split-usr ssl startup-notification svg sysprof systemd tcpd tiff truetype udev udisks unicode upower usb v4l vaapi vdpau vorbis wayland wxwidgets x264 xattr xcb xml xv xvid zeroconf zlib" ABI_X86="64" ADA_TARGET="gnat_2018" ALSA_CARDS="hda-intel ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt rdrand sha sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse synaptics libinput" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres12 postgres13" PYTHON_SINGLE_TARGET="python3_9" PYTHON_TARGETS="python3_9" RUBY_TARGETS="ruby26" USERLAND="GNU" VIDEO_CARDS="vesa radeon nvidia intel amdgpu dummy fbdev nouveau radeonsi v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 2 Sam James archtester gentoo-dev Security 2021-09-13 07:49:08 UTC
No build.log attached? ;)
Comment 3 Kobboi 2021-09-13 07:52:00 UTC
Created attachment 739168 [details]
build.log.gz
Comment 4 Kobboi 2021-09-13 07:52:47 UTC
(In reply to Sam James from comment #2)
> No build.log attached? ;)

Was rebuilding, just in case ;)
Comment 5 MZ 2021-09-13 08:06:11 UTC
same problem.
Comment 6 David Kredba 2021-09-13 10:19:44 UTC
I am trying to build it again with the 3.7.6 version of the bison package.
Comment 7 Manuel Nickschas 2021-09-13 10:20:40 UTC
Seems to be related to the recent upgrade to bison-3.8.1 - can reproduce the build failure with that one, while libreoffice builds fine with bison-3.7.6.
Comment 8 Holger Hoffstätte 2021-09-13 10:35:26 UTC
The bison 3.8.1 NEWS file (https://lists.gnu.org/archive/html/bug-bison/2021-09/msg00022.html) indicates several breaking changes, though offhand I couldn't figure out which one is at work here.
Comment 9 Andrea Postiglione 2021-09-13 12:57:10 UTC
*** Bug 812947 has been marked as a duplicate of this bug. ***
Comment 10 Sam James archtester gentoo-dev Security 2021-09-13 16:52:13 UTC
Could somebody hitting this please report it upstream and link it here? Thanks.
Comment 11 Kobboi 2021-09-13 18:57:08 UTC
(In reply to Sam James from comment #10)
> Could somebody hitting this please report it upstream and link it here?
> Thanks.

Sure, but that will then be via the mailing list, as instructed @ https://wiki.documentfoundation.org/QA/BugReport
Comment 12 Piotr Karbowski archtester Gentoo Infrastructure gentoo-dev Security 2021-09-13 20:50:00 UTC
Can confirm the issue. Works fine with sys-devel/bison-3.7.6, fails with sys-devel/bison-3.8.1.
Comment 13 Larry the Git Cow gentoo-dev 2021-09-14 06:01:28 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ba5edbdf41149115273f3e69d37ba5200ff62d60

commit ba5edbdf41149115273f3e69d37ba5200ff62d60
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-09-14 06:00:47 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-09-14 06:00:47 +0000

    app-office/libreoffice: add Bison 3.8.1 upper bound
    
    Seems to cause build failures.
    
    Bug: https://bugs.gentoo.org/812923
    Signed-off-by: Sam James <sam@gentoo.org>

 app-office/libreoffice/libreoffice-7.1.6.2.ebuild | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
Comment 14 Andrea Postiglione 2021-09-14 11:01:46 UTC
i have opened a bug report to libreoffice bugzilla.

https://bugs.documentfoundation.org/show_bug.cgi?id=144487
Comment 15 Kobboi 2021-09-14 11:06:11 UTC
They replied, a patch is in:

https://git.libreoffice.org/core/+/abeb3847b290c46138960933f18362c5b8a95c17%5E%21

I can test/do a PR for this?
Comment 16 Kobboi 2021-09-14 11:49:27 UTC
I am testing the patch with both bison versions and will make a PR
Comment 17 Andrea Postiglione 2021-09-14 12:07:22 UTC
with bison 3.8.1 and the patch build correctly
Comment 18 Larry the Git Cow gentoo-dev 2021-09-14 13:39:42 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bb92360d332e021a36ed663263ef01e565a9e529

commit bb92360d332e021a36ed663263ef01e565a9e529
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2021-09-14 13:04:49 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2021-09-14 13:39:15 +0000

    app-office/libreoffice: Fix build with >=sys-devel/bison-3.8
    
    Revert sys-devel/bison upper bound.
    
    See also:
    https://lists.freedesktop.org/archives/libreoffice/2021-September/087852.html
    
    Upstream commit 45227d9b79dc4f2a2aa6874cd4e3c02b7934b197
    
    Closes: https://bugs.gentoo.org/812923
    Package-Manager: Portage-3.0.23, Repoman-3.0.3
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 .../files/libreoffice-7.1.5.2-bison-3.8.patch      | 53 ++++++++++++++++++++++
 app-office/libreoffice/libreoffice-7.1.5.2.ebuild  |  1 +
 app-office/libreoffice/libreoffice-7.1.6.2.ebuild  |  4 +-
 3 files changed, 56 insertions(+), 2 deletions(-)
Comment 19 Kobboi 2021-09-14 19:33:32 UTC
Remind me to never touch an astum package again
Comment 20 Andreas Sturmlechner gentoo-dev 2021-09-15 11:48:00 UTC
(In reply to Kobboi from comment #19)
> Remind me to never touch an astum package again
What is this about?