Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 811924 - gnome-base/gnome-control-center: can't set time zone
Summary: gnome-base/gnome-control-center: can't set time zone
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2021-09-07 02:42 UTC by Adam
Modified: 2021-10-11 20:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (emerge_info.txt,16.41 KB, text/plain)
2021-09-08 01:11 UTC, Adam

Note You need to log in before you can comment on or make changes to this bug.
Description Adam 2021-09-07 02:42:54 UTC
When I run the "date" command on the terminal, it shows the correct date, time and time zone (ADT). However in gnome 40, the time at the top of the screen is in the wrong time zone (UTC-0). I tried to fix this in gnome-control-center, but when I click the anywhere on time-zone map, it shows the correct time zone for that location for a split-second, then switches it to UTC-0 (anywhere I click on the map).
Comment 1 Adam 2021-09-07 02:43:45 UTC
I should mention that I've installed gnome-base/gnome-light, not the full gnome-base/gnome
Comment 2 Adam 2021-09-07 02:49:58 UTC
interestingly, it works when I run gnome-control-center as root (with sudo), but it isn't applied to my normal user. So it is probably something to do with permissions
Comment 3 Mart Raudsepp gentoo-dev 2021-09-07 10:41:21 UTC
Missing emerge --info, primarily don't know if this is systemd (localed) or openrc (openrc-settingsd)
Comment 4 Adam 2021-09-08 01:11:33 UTC
(In reply to Mart Raudsepp from comment #3)
> Missing emerge --info, primarily don't know if this is systemd (localed) or
> openrc (openrc-settingsd)

Sorry. It's openrc.
Comment 5 Adam 2021-09-08 01:11:58 UTC
Created attachment 738097 [details]
emerge --info
Comment 6 Adam 2021-10-11 20:13:13 UTC
the problem was bad permissions on /etc/timezone. doing "sudo ls -l /etc/timezone" returned "-rw------- 1 root root 16 Sep 15 14:16 /etc/timezone", so I just used chmod to give myself read permissions.
Comment 7 Adam 2021-10-11 20:15:46 UTC
I don't know why my /etc/timezone had weird permissions, but I think this was a system-specific issue.