Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 810601 - net-analyzer/scli-0.4.0-r2 calls ar directly
Summary: net-analyzer/scli-0.4.0-r2 calls ar directly
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2021-08-27 05:10 UTC by Agostino Sarubbo
Modified: 2021-10-07 08:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,116.82 KB, text/plain)
2021-08-27 05:10 UTC, Agostino Sarubbo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2021-08-27 05:10:40 UTC
https://blogs.gentoo.org/ago/2020/07/04/gentoo-tinderbox/

Issue: net-analyzer/scli-0.4.0-r2 calls ar directly.
Discovered on: amd64 (internal ref: ci)

NOTE:
This machine uses GCC-11: https://gcc.gnu.org/gcc-11/porting_to.html
As per QA policy, toolchain tools must not be called directly because they can cause issue in cross-compiling and because is not possible use a different AR implementation (like llvm-ar). To reproduce, please use sys-devel/gcc-config[-native-symlinks], sys-devel/binutils-config[-native-symlinks].
Comment 1 Agostino Sarubbo gentoo-dev 2021-08-27 05:10:42 UTC
CC'ing also the author of the commit (add260b086539850ff90c0278459915e38ba255d)
Comment 2 Agostino Sarubbo gentoo-dev 2021-08-27 05:10:44 UTC
Created attachment 736201 [details]
build.log

build log and emerge --info
Comment 3 Agostino Sarubbo gentoo-dev 2021-08-27 05:10:47 UTC
Possible context of error(s):

make[2]: ar: No such file or directory
Comment 4 Larry the Git Cow gentoo-dev 2021-10-07 08:30:15 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=7a4d31b37aca9917bb4342324f222b25c789ac1e

commit 7a4d31b37aca9917bb4342324f222b25c789ac1e
Author:     Jakov Smolić <jsmolic@gentoo.org>
AuthorDate: 2021-10-07 08:27:53 +0000
Commit:     Jakov Smolić <jsmolic@gentoo.org>
CommitDate: 2021-10-07 08:29:58 +0000

    net-analyzer/scli: treeclean
    
    Closes: https://bugs.gentoo.org/644344
    Closes: https://bugs.gentoo.org/810601
    Closes: https://bugs.gentoo.org/672176
    Closes: https://bugs.gentoo.org/672174
    Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>

 net-analyzer/scli/Manifest                         |  1 -
 net-analyzer/scli/files/scli-0.4.0-configure.patch | 44 ----------------------
 net-analyzer/scli/metadata.xml                     | 11 ------
 net-analyzer/scli/scli-0.4.0-r2.ebuild             | 35 -----------------
 profiles/package.mask                              |  5 ---
 5 files changed, 96 deletions(-)