Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 809617 - [TEST] dev-util/protobuf-cucumber-3.10.8-r1 - <internal:/.../kernel_require.rb>:85:in require: cannot load such file -- active_sup
Summary: [TEST] dev-util/protobuf-cucumber-3.10.8-r1 - <internal:/.../kernel_require.r...
Status: RESOLVED DUPLICATE of bug 424339
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Hans de Graaff
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2021-08-22 18:05 UTC by Toralf Förster
Modified: 2021-08-27 07:27 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,16.71 KB, text/plain)
2021-08-22 18:05 UTC, Toralf Förster
Details
dev-util:protobuf-cucumber-3.10.8-r1:20210822-171754.log (dev-util:protobuf-cucumber-3.10.8-r1:20210822-171754.log,12.60 KB, text/plain)
2021-08-22 18:05 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,403.09 KB, text/plain)
2021-08-22 18:05 UTC, Toralf Förster
Details
environment (environment,82.57 KB, text/plain)
2021-08-22 18:05 UTC, Toralf Förster
Details
etc.portage.tar.bz2 (etc.portage.tar.bz2,28.59 KB, application/x-bzip)
2021-08-22 18:05 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2021-08-22 18:05:42 UTC
This will be rejected in the future unless you explicitly pass the options `check_default_type: false` or call `allow_incompatible_default_type!` in your code
You can silence deprecations warning by setting the environment variable THOR_SILENCE_DEPRECATION.
<internal:/usr/lib64/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require': cannot load such file -- active_support/core_ext/object/blank (LoadError)
	from <internal:/usr/lib64/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from /var/tmp/portage/dev-util/protobuf-cucumber-3.10.8-r1/work/ruby26/protobuf-cucumber-3.10.8/lib/protobuf.rb:7:in `<top (required)>'
	from <internal:/usr/lib64/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'
	from <internal:/usr/lib64/ruby/site_ruby/3.0.0/rubygems/core_ext/kernel_require.rb>:85:in `require'

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1_hardened-j4_test-20210817-100010

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-11.2.0 *
/usr/lib/llvm/12
12.0.1
Python 3.9.6
Available Ruby profiles:
  [1]   ruby26 (with Rubygems)
  [2]   ruby30 (with Rubygems) *
Available Rust versions:
  [1]   rust-1.54.0 *
The following VMs are available for generation-2:
Available Java Virtual Machines:
  (none found)

The Glorious Glasgow Haskell Compilation System, version 8.10.4

  HEAD of ::gentoo
commit 6bf0bd9956b5dad48bbf0ec376b27efa7173bdd4
Author: Repository mirror & CI <repomirrorci@gentoo.org>
Date:   Sun Aug 22 15:45:03 2021 +0000

    2021-08-22 15:44:45 UTC

emerge -qpvO dev-util/protobuf-cucumber
[ebuild  N    ] dev-util/protobuf-cucumber-3.10.8-r1  USE="test -doc" RUBY_TARGETS="ruby26 -ruby27"
Comment 1 Toralf Förster gentoo-dev 2021-08-22 18:05:44 UTC
Created attachment 735100 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2021-08-22 18:05:45 UTC
Created attachment 735103 [details]
dev-util:protobuf-cucumber-3.10.8-r1:20210822-171754.log
Comment 3 Toralf Förster gentoo-dev 2021-08-22 18:05:47 UTC
Created attachment 735106 [details]
emerge-history.txt
Comment 4 Toralf Förster gentoo-dev 2021-08-22 18:05:49 UTC
Created attachment 735109 [details]
environment
Comment 5 Toralf Förster gentoo-dev 2021-08-22 18:05:50 UTC
Created attachment 735112 [details]
etc.portage.tar.bz2
Comment 6 Hans de Graaff gentoo-dev 2021-08-27 07:27:41 UTC

*** This bug has been marked as a duplicate of bug 424339 ***