Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 808984 (CVE-2021-3677) - <dev-db/postgresql-{11.13, 12.8, 13.4}: Memory disclosure (CVE-2021-3677)
Summary: <dev-db/postgresql-{11.13, 12.8, 13.4}: Memory disclosure (CVE-2021-3677)
Status: IN_PROGRESS
Alias: CVE-2021-3677
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://www.postgresql.org/about/news...
Whiteboard: B4 [glsa?]
Keywords:
Depends on: CVE-2021-23214, CVE-2021-23222
Blocks:
  Show dependency tree
 
Reported: 2021-08-19 03:44 UTC by Sam James
Modified: 2021-12-17 06:19 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-08-19 03:44:47 UTC
CVE-2021-3677: Memory disclosure in certain queries

Versions Affected: 11 - 13.

"A purpose-crafted query can read arbitrary bytes of server memory. In the default configuration, any authenticated database user can complete this attack at will. The attack does not require the ability to create objects. If server settings include max_worker_processes=0, the known versions of this attack are infeasible. However, undiscovered variants of the attack may be independent of that setting."
Comment 1 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-08-19 03:45:51 UTC
Please bump 13.4, 12.8, 11.13.
Comment 2 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-08-19 03:46:12 UTC
If/when it's ready to stable, please file a new stabilisation bug and have it block this one. Thanks!