Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 807058 (CVE-2021-38115) - media-libs/gd: OOB read (CVE-2021-38115)
Summary: media-libs/gd: OOB read (CVE-2021-38115)
Status: CONFIRMED
Alias: CVE-2021-38115
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal minor (vote)
Assignee: Gentoo Security
URL: https://github.com/libgd/libgd/issues...
Whiteboard: B3 [upstream/ebuild]
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-07 22:47 UTC by John Helmert III
Modified: 2021-08-07 22:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Helmert III gentoo-dev Security 2021-08-07 22:47:01 UTC
CVE-2021-38115:

read_header_tga in gd_tga.c in the GD Graphics Library (aka LibGD) through 2.3.2 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted TGA file.

Unreleased patch: https://github.com/libgd/libgd/commit/edaf39fe6fb0d1867b9b5992efb9fe4102138553