Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80627 - With Udev enable, and devfs disabled cannot mount / readable during boot.
Summary: With Udev enable, and devfs disabled cannot mount / readable during boot.
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2005-02-03 13:08 UTC by Paul Kelly
Modified: 2005-04-26 22:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Paul Kelly 2005-02-03 13:08:30 UTC
I have tried 4 different kernels starting at 2.6.9-gentoo-something and the most recent being 2.6.10-gentoo-r5. (sorry, they didn't work so I deleted them) devfs must be enabled and compiled in to boot successfully. The error is cannot read superblock on /dev/sda3. (Sda3 is / on a WD SATA drive attached to a 3ware 7002 SATA RAID with RAID-1 mirrored drives.) It also complains that the filesystem is ext2 but the filesystem is actually ext3. After the failure it drops to the "fsck the filesystem prompt" and suggests using a different/alternate superblock. It does show the messages during boot that it recognizes the adapter and drives and in fact mounts the same filesystem (/sda3) read-only. It is remountable read-write.

Reproducible: Always
Steps to Reproduce:
1.change grub.conf to boot udev (add gentoo=nodevfs, remove root=/dev/ram0 and real_root=/dev/sda3 flags.)

Actual Results:  
previously documented error
Comment 1 SpanKY gentoo-dev 2005-02-04 05:48:11 UTC
you neglected to provide `emerge info` like the bug report page told you to
Comment 2 Dmitri Pogosian 2005-02-27 23:12:13 UTC
As a comment of support - I have experienced exactly the same on 3ware9000 SATA 
raid5 controller (2.6.9-r14 kernel on amd64 dual opteron) on my first, and only try of udev. I have deleted udev since, so can't provide more information.
Comment 3 BlinkEye 2005-04-26 03:09:56 UTC
i do have exactly the same problem with a amd64 system and a raid0. it's reproducable always while doing a system backup (see which doesn't inlcude the /dev/*). it has nothing to do with the backup script but solely with udev. if i boot the system with gentoo=noudev, i.e. using devfs it actually boots. 
i could provide as much info as you want me to, i got it back working (somehow after booting it once with devfs udev is back working). nevertheless i'm not able to boot a backup of my laptop (udev) extracted on a usb harddisk. same error as the author of this bug, but the device /dev/sda1 is missing.

i'd really appreciate any help in solving this issue as i'm not the only one who uses my backup script.
Comment 4 SpanKY gentoo-dev 2005-04-26 20:58:10 UTC
that sounds like a genkernel issue
Comment 5 Paul Kelly 2005-04-26 22:36:01 UTC
This bug disappeared with kernel 2.6.11