Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 80455 - revdep-rebuild can miss broken packages under certain circumstances
Summary: revdep-rebuild can miss broken packages under certain circumstances
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Portage Tools Team
: 58346 80557 80695 81810 96486 100207 (view as bug list)
Depends on: 62644
Blocks: 346443
  Show dependency tree
Reported: 2005-02-02 06:18 UTC by Peter Jensen
Modified: 2012-12-25 01:50 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Peter Jensen 2005-02-02 06:18:32 UTC
This morning libdv was upgraded, and this broke mplayer.
Therefore I ran revdep-rebuild to scan for other broken packages, but found that it totally missed the broken mplayer binary.
A lot of trial and error showed that when /opt/vmware/lib/lib was in the LD_LIBRARY_PATH before /usr/lib, then ldd would try to get from vmware instead.
However, since /opt/vmware/lib/lib/ is actually a directory, ldd fails completely with this message (which is redirected to /dev/null):

/usr/bin/mplayer: error while loading shared libraries: /opt/vmware/lib/lib/ cannot read file data: Error 21

The fact that the libdv link is also broken is not registered.
So, it seems to me that a lot of broken dependencies could go unnoticed for quite some time if you have vmware installed.
Not sure how it should be solved, though.
Comment 1 Paul Varner (RETIRED) gentoo-dev 2005-02-02 11:12:10 UTC
The updated revdep-rebuild script in bug #62644 should handle this situation the majority of the time.  It ensures that the standard library locations are listed first in the LD_LIBRARY_PATH.
Comment 2 Andre Hinrichs 2005-02-04 06:36:59 UTC
*** Bug 80695 has been marked as a duplicate of this bug. ***
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-04 09:19:24 UTC
*** Bug 80557 has been marked as a duplicate of this bug. ***
Comment 4 Carsten Lohrke (RETIRED) gentoo-dev 2005-02-12 17:56:44 UTC
*** Bug 81810 has been marked as a duplicate of this bug. ***
Comment 5 Rene Androsch 2005-02-13 04:45:01 UTC
Instead of marking similar bugs as closed - start providing a good fix the distriubtes fast via portage, so that
a) systems get fixed soon
b) systems stop getting broken
c) bug reports stoping poping up

I did a search on the forums and on the bug database AND DID NOT find any solution, why seems to be missing on my system. I also noticed it by an error message of mplayer. After revdep-rebuild I noticed that several applications are broken.

Since I', doing nearly daily: "emerge --sync ; emerge --newuse -vD world" my system is supposed to be up2date.

And I DO NOT have vmware installed on my system - so this can't be it.
Comment 6 Robert Trace 2005-04-16 22:42:32 UTC
BTW, the reason you get the Error 21 from ldd is because of a bug in glibc's dynamic loader.  see bug #89381.
Comment 7 yuk 2005-04-28 01:52:17 UTC
See also bug #58346, I posted a patch it works for me.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-06-18 17:28:15 UTC
*** Bug 96486 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2005-12-03 07:16:37 UTC
*** Bug 58346 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2005-12-03 07:28:55 UTC
*** Bug 100207 has been marked as a duplicate of this bug. ***
Comment 11 Piotr Malinski 2006-01-06 11:21:37 UTC
Revdep-rebuild finds after new dbus installation:
Checking dynamic linking consistency...
  broken /usr/kde/3.5/lib/kde3/ (requires
  broken /usr/lib/ (requires

Assigning files to ebuilds... done.

Evaluating package order... done.

All prepared. Starting rebuild...
emerge --oneshot  =app-cdr/k3b-0.12.10
where "equery b" points out also kdebase-kioslaves. After reemerging kdebase-kioslaves "broken /usr/kde/3.5/lib/kde3/ (requires" dissapears from the revdep-rebuild list.
Comment 12 Patrizio Bassi 2006-01-06 11:47:59 UTC
and shouldn't? that's what it has to do!
Comment 13 Piotr Malinski 2006-01-07 08:49:17 UTC
revdep should find kdebase-kioslaves as broken package for re-emerge
Comment 14 DEMAINE Benoît-Pierre, aka DoubleHP 2007-02-24 17:33:16 UTC
in bug #96946 comment #38 , it is said that this bug is fixed. Please check and close.
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2007-08-13 10:40:26 UTC

*** This bug has been marked as a duplicate of bug 96946 ***
Comment 16 Paul Varner (RETIRED) gentoo-dev 2007-08-15 02:33:36 UTC
Not the same bug as #96946 and it is not fixed.
Comment 17 Paul Varner (RETIRED) gentoo-dev 2011-07-20 04:11:54 UTC
This should be fixed when we convert to scanelf to check for breakage in the python rewrite of revdep-rebuild being developed for gentoolkit-0.3.1