Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 804136 - dev-python/pandas: full keywording
Summary: dev-python/pandas: full keywording
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Science Related Packages
URL:
Whiteboard:
Keywords: CC-ARCHES
Depends on: 804118 804115
Blocks:
  Show dependency tree
 
Reported: 2021-07-25 11:20 UTC by Michał Górny
Modified: 2022-03-18 12:40 UTC (History)
1 user (show)

See Also:
Package list:
dev-python/pandas alpha ia64 hppa ppc ppc64 sparc s390 dev-python/blosc alpha ia64 hppa ppc ppc64 sparc s390 dev-python/bottleneck alpha ia64 hppa ppc ppc64 sparc s390 dev-python/numexpr alpha ia64 hppa ppc ppc64 sparc s390 dev-python/openpyxl alpha ia64 hppa ppc ppc64 sparc s390 dev-python/pymysql alpha ia64 hppa ppc ppc64 sparc s390 dev-python/pytables alpha ia64 hppa ppc ppc64 sparc s390 dev-python/xarray alpha ia64 hppa ppc ppc64 sparc s390 dev-python/xlrd alpha ia64 hppa ppc ppc64 sparc s390 dev-python/xlsxwriter alpha ia64 hppa ppc ppc64 sparc s390 x11-misc/xsel alpha ia64 hppa ppc ppc64 sparc s390 dev-libs/c-blosc alpha ia64 hppa ppc ppc64 sparc s390 dev-python/et_xmlfile alpha ia64 hppa ppc ppc64 sparc s390 dev-python/patsy alpha ia64 hppa ppc ppc64 sparc s390 dev-python/scikit-build alpha ia64 hppa ppc ppc64 sparc s390 dev-python/toolz alpha ia64 hppa ppc ppc64 sparc s390 dev-python/distro alpha ia64 hppa ppc ppc64 sparc s390 dev-python/statsmodels alpha
Runtime testing required: ---
sam: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2021-07-25 11:20:42 UTC
Another step in getting Python keywordings in sync.
Comment 1 NATTkA bot gentoo-dev 2021-07-25 11:24:21 UTC Comment hidden (obsolete)
Comment 2 NATTkA bot gentoo-dev 2021-07-25 11:56:22 UTC Comment hidden (obsolete)
Comment 3 NATTkA bot gentoo-dev 2021-07-25 12:08:22 UTC Comment hidden (obsolete)
Comment 4 NATTkA bot gentoo-dev 2021-07-25 12:40:31 UTC Comment hidden (obsolete)
Comment 5 NATTkA bot gentoo-dev 2021-07-25 12:48:20 UTC Comment hidden (obsolete)
Comment 6 NATTkA bot gentoo-dev 2021-07-25 12:56:29 UTC Comment hidden (obsolete)
Comment 7 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-09-06 00:12:47 UTC
ppc done
Comment 8 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-09-06 23:37:44 UTC
ppc64 done
Comment 9 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-09-06 23:42:33 UTC
s390 done
Comment 10 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-14 03:43:27 UTC
ia64 done
Comment 11 NATTkA bot gentoo-dev 2021-11-14 15:53:13 UTC Comment hidden (obsolete)
Comment 12 NATTkA bot gentoo-dev 2021-11-18 10:52:53 UTC Comment hidden (obsolete)
Comment 13 Larry the Git Cow gentoo-dev 2021-11-18 10:57:33 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=9d0466c8a099844136529535674bf6c21cd3cfc5

commit 9d0466c8a099844136529535674bf6c21cd3cfc5
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-11-18 10:56:51 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-11-18 10:57:17 +0000

    dev-python/pandas: try avoid scipy dependency on HPPA
    
    scipy doesn't build on HPPA. Pandas seems to fall back
    OK w/o scipy installed.
    
    Bug: https://bugs.gentoo.org/804136
    Bug: https://bugs.gentoo.org/804115
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-python/pandas/pandas-1.3.4.ebuild | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 14 NATTkA bot gentoo-dev 2021-11-18 11:00:47 UTC Comment hidden (obsolete)
Comment 15 NATTkA bot gentoo-dev 2021-11-18 11:04:51 UTC
Sanity check failed:

> dev-python/statsmodels-0.13.1
>   bdepend ~hppa stable profile default/linux/hppa/17.0 (2 total)
>     >=dev-python/scipy-1.3[python_targets_python3_8(-),python_targets_python3_9(-)]
>   depend ~hppa stable profile default/linux/hppa/17.0 (2 total)
>     >=dev-python/scipy-1.3[python_targets_python3_8(-),python_targets_python3_9(-)]
>   rdepend ~hppa stable profile default/linux/hppa/17.0 (2 total)
>     >=dev-python/scipy-1.3[python_targets_python3_8(-),python_targets_python3_9(-)]
Comment 16 Larry the Git Cow gentoo-dev 2021-11-18 11:06:32 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=b1f85489edb3d36e24456d3d7364da38575df4fb

commit b1f85489edb3d36e24456d3d7364da38575df4fb
Author:     Sam James <sam@gentoo.org>
AuthorDate: 2021-11-18 11:05:59 +0000
Commit:     Sam James <sam@gentoo.org>
CommitDate: 2021-11-18 11:05:59 +0000

    dev-python/pandas: avoid scipy dep (via statsmodels) on HPPA
    
    scipy doesn't build on HPPA and statsmodels is barely a dependency
    of pandas anyway (and it's only dragged in on HPPA for tests).
    
    Bug: https://bugs.gentoo.org/804115
    Bug: https://bugs.gentoo.org/804136
    Signed-off-by: Sam James <sam@gentoo.org>

 dev-python/pandas/pandas-1.3.4.ebuild | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
Comment 17 Sam James archtester Gentoo Infrastructure gentoo-dev Security 2021-11-20 06:35:40 UTC
hppa done
Comment 18 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2022-03-18 12:40:48 UTC
Let's forget about it.