Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 803260 - www-client/google-chrome-92.0.4515.107 freezes with sys-apps/systemd-249.1
Summary: www-client/google-chrome-92.0.4515.107 freezes with sys-apps/systemd-249.1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Chromium Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-21 17:33 UTC by Fabio Coatti
Modified: 2021-08-03 09:54 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabio Coatti 2021-07-21 17:33:24 UTC
With systemd-249.1, chrome freezes basically immediately. Console messages:
 [0721/192016.856849:WARNING:process_reader_linux.cc(125)] no stack mapping
[68603:68603:0721/192017.095469:ERROR:vaapi_wrapper.cc(1068)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[68603:68603:0721/192017.095622:ERROR:vaapi_wrapper.cc(1015)] FillProfileInfo_Locked failed for va_profile VAProfileH264Main and entrypoint VAEntrypointVLD
[68603:68603:0721/192017.095688:ERROR:vaapi_wrapper.cc(1068)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[68603:68603:0721/192017.095735:ERROR:vaapi_wrapper.cc(1015)] FillProfileInfo_Locked failed for va_profile VAProfileH264High and entrypoint VAEntrypointVLD
[68558:68558:0721/192017.163775:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[68558:68558:0721/192018.396349:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[68558:68558:0721/192021.142968:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[68558:68558:0721/192023.837400:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[0721/192023.897466:ERROR:ptracer.cc(422)] ptrace: No such process (3)
[0721/192023.897483:ERROR:ptracer.cc(446)] Unexpected registers size 0 != 216
[0721/192023.897490:WARNING:process_reader_linux.cc(378)] Couldn't initialize main thread.
[0721/192024.350354:ERROR:scoped_ptrace_attach.cc(37)] process not stopped
[0721/192024.352591:ERROR:scoped_ptrace_attach.cc(37)] process not stopped
[0721/192024.352615:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[0721/192024.352624:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[0721/192024.352629:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[0721/192024.352634:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[0721/192024.352640:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[0721/192024.352646:ERROR:scoped_ptrace_attach.cc(27)] ptrace: No such process (3)
[0721/192024.352659:ERROR:file_io_posix.cc(144)] open /proc/68871/auxv: Permission denied (13)
[0721/192024.352669:ERROR:process_memory.cc(41)] short read
[0721/192024.352674:ERROR:process_snapshot_linux.cc(75)] Couldn't read exception info
[0721/192024.352710:ERROR:scoped_ptrace_attach.cc(45)] ptrace: No such process (3)
[0721/192024.352750:ERROR:scoped_ptrace_attach.cc(27)] ptrace: Operation not permitted (1)

The interesting part should be the network-related error. I suspect something with systemd-resolved, because stopping it unfreezes the browser (that shows an unknown fqdn error, but this is expected)

Same browser after downgrading to systemd-248.5:

google-chrome-stable   
[35669:35669:0721/190044.714779:ERROR:vaapi_wrapper.cc(1068)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[35669:35669:0721/190044.714848:ERROR:vaapi_wrapper.cc(1015)] FillProfileInfo_Locked failed for va_profile VAProfileH264Main and entrypoint VAEntrypointVLD
[35669:35669:0721/190044.714938:ERROR:vaapi_wrapper.cc(1068)] vaQuerySurfaceAttributes failed, VA error: invalid parameter
[35669:35669:0721/190044.714976:ERROR:vaapi_wrapper.cc(1015)] FillProfileInfo_Locked failed for va_profile VAProfileH264High and entrypoint VAEntrypoint

And then the browser works just fine.


Reproducible: Always




Portage 3.0.20 (python 3.9.6-final-0, default/linux/amd64/17.1/desktop/plasma/systemd, gcc-11.1.0, glibc-2.33-r3, 5.13.4-cova x86_64)
=================================================================
System uname: Linux-5.13.4-cova-x86_64-Intel-R-_Core-TM-_i7-6820HQ_CPU_@_2.70GHz-with-glibc2.33
KiB Mem:    65678744 total,  54774192 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of repository gentoo: Wed, 21 Jul 2021 16:32:51 +0000
Head commit of repository gentoo: 7a6f20ef8855f411fa877965e9e83ee5839212e0

sh bash 5.1_p8
ld GNU gold (Gentoo 2.36.1 p3 2.36.1) 1.16
app-shells/bash:          5.1_p8::gentoo
dev-java/java-config:     2.3.1::gentoo
dev-lang/perl:            5.34.0-r1::gentoo
dev-lang/python:          2.7.18_p11::gentoo, 3.8.11::gentoo, 3.9.6::gentoo, 3.10.0_beta4::gentoo
dev-lang/rust:            1.53.0::gentoo
dev-util/cmake:           3.21.0::gentoo
dev-util/pkgconfig:       0.29.2::gentoo
sys-apps/baselayout:      2.7-r3::gentoo
sys-apps/sandbox:         2.24::gentoo
sys-devel/autoconf:       2.13-r1::gentoo, 2.69-r5::gentoo
sys-devel/automake:       1.13.4-r2::gentoo, 1.16.3-r1::gentoo
sys-devel/binutils:       2.36.1-r1::local
sys-devel/gcc:            8.5.0-r1::gentoo, 9.3.0-r2::gentoo, 11.1.0-r2::gentoo
sys-devel/gcc-config:     2.4::gentoo
sys-devel/libtool:        2.4.6-r6::gentoo
sys-devel/make:           4.3::gentoo
sys-kernel/linux-headers: 5.13::gentoo (virtual/os-headers)
sys-libs/glibc:           2.33-r3::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: git
    sync-uri: https://anongit.gentoo.org/git/repo/sync/gentoo.git
    priority: -1000
    sync-git-verify-commit-signature: yes

kde
    location: /var/lib/layman/kde
    sync-type: laymansync
    sync-uri: https://anongit.gentoo.org/git/proj/kde.git
    masters: gentoo
    priority: 50

nvidia-docker-overlay
    location: /var/lib/layman/nvidia-docker-overlay
    sync-type: laymansync
    sync-uri: https://github.com/gronastech/nvidia-docker-overlay.git
    masters: gentoo
    priority: 50

local
    location: /usr/overlay
    masters: gentoo
    priority: 51

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O3 -fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -flto=4 -fuse-linker-plugin -pipe -fpie -fpic -fstack-protector-strong -fstack-clash-protection"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/sddm/scripts/Xsetup"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O3 -fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -flto=4 -fuse-linker-plugin -pipe -fpie -fpic -fstack-protector-strong -fstack-clash-protection"
DISTDIR="/usr/portage/distfiles"
ENV_UNSET="CARGO_HOME DBUS_SESSION_BUS_ADDRESS DISPLAY GOBIN GOPATH PERL5LIB PERL5OPT PERLPREFIX PERL_CORE PERL_MB_OPT PERL_MM_OPT XAUTHORITY XDG_CACHE_HOME XDG_CONFIG_HOME XDG_DATA_HOME XDG_RUNTIME_DIR"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs binpkg-multi-instance clean-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned qa-unresolved-soname-deps sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.eu.oneandone.net/linux/distributions/gentoo/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/"
LANG="en_IE.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -march=native -O3 -fgraphite-identity -floop-nest-optimize -ftree-loop-distribution -flto=4 -fuse-linker-plugin -pipe -fpie -fpic -fstack-protector-strong -fstack-clash-protection -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="en it de"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext 3dnowprefetch X \ a52 aac aalib acl acpi activities aim alsa amd64 apng appstream ares asf ati audio audiofile avahi bash-completion bidi bl bluetooth branding bri bzip2 cairo caps cdda cdr cjk cli crypt cups curl dba dbus declarative device-mapper dga divx divx4linux dri dts dv dvb dvd dvdr dvdread eap-sim edl egl emboss encode ethereal evdev exif expat faad fam fame fbcon ffmpeg fftw flac force-cgi-redirect fortran ftp gallium garmin gd gdbm gif gimp gmedia gmp gnutls gphoto2 gpm gps gsm gtk gui h264 h323 iconv icq icu idn ifp ilbc imagemagick imap innodb ipod iproute2 ipv6 ithreads jabber java javascript joystick jpeg kde kipi kontact kvm kwallet lastfm lcms libglvnd libnotify libtirpc libvirtd live lm_sensors lua lvm lxc lzma lzo mad maildir matroska mbox mdnsresponder-compat mhash mime mjpeg mmap mmx mmxext mng mozdevelop mozilla mp3 mp4 mpeg msn mtp multilib mysql ncurses network networkmanager new-hpcups nfsv4 njb nls nptl nptlonly offensive ofx ogg oggvorbis ogm openal openexr opengl openmp oscar pam pango parted pcap pcre pdf phonon php plasma plotutils png policykit ppds pulseaudio qemu qml qt5 readline real rtc ruby samba sasl sdl seccomp semantic-desktop semantic-destkop sha512 sip slang slp smartcard sndfile snmp sox speex spell split-usr srt sse sse2 ssh ssl ssse3 startup-notification svg symlink systemd tcltk tcpd telepathy theora threads tiff tk touchpad tremor truetype udev udisks unicode upower usb utempter v4l v4l2 vaapi vcd vde vdpaum vhosts video videos vim-syntax virt-network virtualbox vorbis vulkan wav wayland widgets wifi wmf wmp wps wxwidgets wxwindows x264 xanim xattr xcb xface xft xine xinerama xml xosd xpm xscreensaver xsl xv xvid zeroconf zlib zpm" ABI_X86="64 32" ADA_TARGET="gnat_2018" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="karbon sheets words" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx avx2 f16c fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock greis isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="libinput" KERNEL="linux" L10N="en it de en_IE" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LLVM_TARGETS="X86" LUA_SINGLE_TARGET="lua5-1" LUA_TARGETS="lua5-1" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3 php7-4" POSTGRES_TARGETS="postgres10 postgres11" PYTHON_SINGLE_TARGET="python3_8" PYTHON_TARGETS="python3_8 python3_9" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby26 ruby27 ruby30" USERLAND="GNU" VIDEO_CARDS="i965 intel nvidia v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq proto steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, RUSTFLAGS
Comment 1 Mike Gilbert gentoo-dev 2021-07-21 17:36:35 UTC
Have you tried rebooting after upgrading to 249.1?
Comment 2 Fabio Coatti 2021-07-21 17:48:18 UTC
(In reply to Mike Gilbert from comment #1)
> Have you tried rebooting after upgrading to 249.1?

Yup, sure.
Comment 5 Mike Gilbert gentoo-dev 2021-07-21 18:09:37 UTC
It looks like this is a bug in Chrome. Unfortunately, we will have to wait for Google to ship a new build with the fix.

In the meantime, I would suggest disabling nss-resolve (remove it from /etc/nsswitch.conf).
Comment 6 Larry the Git Cow gentoo-dev 2021-07-24 09:48:44 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=774d25d68d6fce0e1fc0168f50f515c988e6ebf6

commit 774d25d68d6fce0e1fc0168f50f515c988e6ebf6
Author:     Stephan Hartmann <sultan@gentoo.org>
AuthorDate: 2021-07-24 09:47:31 +0000
Commit:     Stephan Hartmann <sultan@gentoo.org>
CommitDate: 2021-07-24 09:48:39 +0000

    www-client/chromium: stable channel bump to 92.0.4515.107
    
    Bug: https://bugs.gentoo.org/803167
    Bug: https://bugs.gentoo.org/803467
    Bug: https://bugs.gentoo.org/769989
    Bug: https://bugs.gentoo.org/803260
    Package-Manager: Portage-3.0.20, Repoman-3.0.2
    Signed-off-by: Stephan Hartmann <sultan@gentoo.org>

 www-client/chromium/Manifest                       |  3 +-
 ...515.80.ebuild => chromium-92.0.4515.107.ebuild} | 16 +++----
 .../files/chromium-92-GetUsableSize-nullptr.patch  | 46 ++++++++++++++++++++
 .../chromium/files/chromium-freetype-2.11.patch    | 50 ++++++++++++++++++++++
 4 files changed, 103 insertions(+), 12 deletions(-)
Comment 7 Fabio Coatti 2021-07-26 08:16:51 UTC
(In reply to Mike Gilbert from comment #5)
> It looks like this is a bug in Chrome. Unfortunately, we will have to wait
> for Google to ship a new build with the fix.
> 
> In the meantime, I would suggest disabling nss-resolve (remove it from
> /etc/nsswitch.conf).

I can live also with old systemd until the issue is fixed, but my nsswitch conf has no direct reference to nss-resolve:

aliases:    files
ethers:     files
group:      files [SUCCESS=merge] systemd
gshadow:    files systemd
hosts:       files mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns
netgroup:   files
networks:   files dns
passwd:     files systemd
protocols:  files
publickey:  files
rpc:        files
shadow:     files systemd
services:   files


I guess "mdns_minimal" can be at fail here, or maybe "systemd" in group?
(admittedly, I have yet to find the time to fiddle around with my config)
Comment 8 Christian Bricart 2021-07-26 13:28:46 UTC
(In reply to Fabio Coatti from comment #7)
> > In the meantime, I would suggest disabling nss-resolve (remove it from
> > /etc/nsswitch.conf).
> 
> I can live also with old systemd until the issue is fixed, but my nsswitch
> conf has no direct reference to nss-resolve:
> 
> [..]
> hosts:       files mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return]
> [..]
> I guess "mdns_minimal" can be at fail here, or maybe "systemd" in group?
> (admittedly, I have yet to find the time to fiddle around with my config)

fyi: actually, it's the »resolve« entry that triggers nss-resolve

'dns' uses /usr/lib/libnss_dns.so. 'resolve' would use /usr/lib/libnss_resolve.so, and so on...
Comment 9 Mike Gilbert gentoo-dev 2021-07-26 15:04:35 UTC
(In reply to Fabio Coatti from comment #7)

Remove "resolve [!UNAVAIL=return]" from the hosts line.
Comment 10 Fabio Coatti 2021-07-26 15:12:24 UTC
(In reply to Mike Gilbert from comment #9)
> (In reply to Fabio Coatti from comment #7)
> 
> Remove "resolve [!UNAVAIL=return]" from the hosts line.

Thanks!!
Comment 11 Larry the Git Cow gentoo-dev 2021-07-26 21:17:14 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=0c8827bdd3d8723d0d84d79787e6c9f241306385

commit 0c8827bdd3d8723d0d84d79787e6c9f241306385
Author:     Stephan Hartmann <sultan@gentoo.org>
AuthorDate: 2021-07-26 21:16:01 +0000
Commit:     Stephan Hartmann <sultan@gentoo.org>
CommitDate: 2021-07-26 21:17:08 +0000

    www-client/chromium: dev channel bump to 93.0.4577.8
    
    Bug: https://bugs.gentoo.org/803260
    Bug: https://bugs.gentoo.org/769989
    Package-Manager: Portage-3.0.20, Repoman-3.0.2
    Signed-off-by: Stephan Hartmann <sultan@gentoo.org>

 www-client/chromium/Manifest                       |  4 +-
 ...0.4557.4.ebuild => chromium-93.0.4577.8.ebuild} | 21 ++----
 .../files/chromium-93-EnumTable-crash.patch        | 79 ++++++++++++++++++++++
 3 files changed, 88 insertions(+), 16 deletions(-)
Comment 12 therjak 2021-08-03 09:13:01 UTC
It seems like the fix was approved and submitted to chrome 92.

https://bugs.chromium.org/p/chromium/issues/detail?id=1221442#c43
https://bugs.chromium.org/p/chromium/issues/detail?id=1221442#c44

Does 92.0.4515.131 already include the fix?
Comment 13 Stephan Hartmann gentoo-dev 2021-08-03 09:54:18 UTC
(In reply to therjak from comment #12)
> It seems like the fix was approved and submitted to chrome 92.
> 
> https://bugs.chromium.org/p/chromium/issues/detail?id=1221442#c43
> https://bugs.chromium.org/p/chromium/issues/detail?id=1221442#c44
> 
> Does 92.0.4515.131 already include the fix?

Yes.