Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 801937 - Translators' requests on wiki are blocked since november 2019
Summary: Translators' requests on wiki are blocked since november 2019
Status: RESOLVED FIXED
Alias: None
Product: Websites
Classification: Unclassified
Component: Wiki (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Wiki Team
URL: https://wiki.gentoo.org/wiki/Gentoo_W...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-12 20:57 UTC by Marco Scardovi (scardracs)
Modified: 2021-09-12 19:21 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Scardovi (scardracs) 2021-07-12 20:57:35 UTC
The translator grant batch is stopped since november. I'm hopening this bug as I'm not the only one that required more than once for it (actually my translation grants were enabled by @ulm) but there are literally 48 translation requests since november.

Please take a look on it because @grknight is not on libera chat yet (as of today).

Reproducible: Always
Comment 1 Marco Scardovi (scardracs) 2021-07-12 20:59:19 UTC
s/hopening/opening/
Comment 2 Ulrich Müller gentoo-dev 2021-07-17 11:55:06 UTC
@Wiki team: I see a large backlog on the "Translator account requests" page (URL).

What is blocking these user accounts to be flagged for translation?
Comment 3 Ulrich Müller gentoo-dev 2021-07-17 12:01:40 UTC
(In reply to Marco Scardovi (scardracs) from comment #0)
> The translator grant batch is stopped since november.

The date stamps of the comments don't include the year, but AFAICS the dates wrap around once. So it is November 2019.
Comment 4 Marco Scardovi (scardracs) 2021-07-18 15:10:40 UTC
(In reply to Ulrich Müller from comment #3)
> (In reply to Marco Scardovi (scardracs) from comment #0)
> > The translator grant batch is stopped since november.
> 
> The date stamps of the comments don't include the year, but AFAICS the dates
> wrap around once. So it is November 2019.

Ah yes, fixed thanks
Comment 5 Ulrich Müller gentoo-dev 2021-08-04 08:34:56 UTC
Translator requests are all done.

Please leave this bug open for new, we may want to discuss in the Council meeting how to prevent this from happening again in the future.
Comment 6 Ulrich Müller gentoo-dev 2021-08-04 08:35:40 UTC
(In reply to Ulrich Müller from comment #5)
> Please leave this bug open for new,

... for _now_.
Comment 7 Brian Evans Gentoo Infrastructure gentoo-dev 2021-08-11 20:43:54 UTC
(In reply to Ulrich Müller from comment #5)
> Translator requests are all done.
> 
> Please leave this bug open for new, we may want to discuss in the Council
> meeting how to prevent this from happening again in the future.

FWIW, I stopped granting things after an initial period of just granting anyone who asked.  The reason?  I have no clue what people are writing in other languages.

It is unclear what a poor translation, let alone a subversive one, may accomplish if there is only one person writing and no "trusted" dev/community member to review.

Translations run the gambit of documents including the install Handbook.

All developers have the ability to do translations themselves if they see fit.  We also have the ability to have "Head Translators" for some additional rights (which I don't recall at this time).
Comment 8 Ulrich Müller gentoo-dev 2021-08-12 04:49:51 UTC
(In reply to Brian Evans from comment #7)
> FWIW, I stopped granting things after an initial period of just granting
> anyone who asked. [...]

But without telling the rest of the team?
Comment 9 Brian Evans Gentoo Infrastructure gentoo-dev 2021-08-12 12:53:04 UTC
(In reply to Ulrich Müller from comment #8)
> (In reply to Brian Evans from comment #7)
> > FWIW, I stopped granting things after an initial period of just granting
> > anyone who asked. [...]
> 
> But without telling the rest of the team?

No, this was communicated at least one or more times in #gentoo-wiki since then.
Comment 10 Matthew Marchese Gentoo Infrastructure gentoo-dev 2021-08-27 07:07:46 UTC
(In reply to Brian Evans from comment #9)
> 
> No, this was communicated at least one or more times in #gentoo-wiki since
> then.

Yes. I can confirm, Grknight and I have discussed this point. Also, I'd say something like 95% of translation requests do not actually perform translation. The 5% that do are not verified, although a few different languages over the years have 'caught up' their language of Handbook translations to the current English source...

Question is, should we remove the extra privileges for translations since they are not verified by the handbook team? Seems like the extra busy work marking accounts doesn't actually accomplish much in added value for the community.

Translations are tough on on us because - apart from dilfridge - we edit the Handbook the most and can't verify the accuracy of translations without a __lot__ of extra work.
Comment 11 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2021-09-12 19:21:47 UTC
The Council has agreed that there's nothing more for us to do here.