Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 79787 - [BUG] net-analyzer/netio-1.23 installs trash into DOCDIR
Summary: [BUG] net-analyzer/netio-1.23 installs trash into DOCDIR
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Netmon Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-01-27 15:45 UTC by Stefan Briesenick (RETIRED)
Modified: 2005-01-28 12:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Briesenick (RETIRED) gentoo-dev 2005-01-27 15:45:29 UTC
# epm -ql netio|sort

/usr/bin/netio
/usr/share/doc/netio-1.23/FILE_ID.DIZ.gz
/usr/share/doc/netio-1.23/getopt.c.gz
/usr/share/doc/netio-1.23/getopt.h.gz
/usr/share/doc/netio-1.23/getopt.o.gz
/usr/share/doc/netio-1.23/Makefile.gz
/usr/share/doc/netio-1.23/netb_1_c.h.gz
/usr/share/doc/netio-1.23/netb_2_c.h.gz
/usr/share/doc/netio-1.23/netbios.c.gz
/usr/share/doc/netio-1.23/netbios.h.gz
/usr/share/doc/netio-1.23/netbios.o.gz
/usr/share/doc/netio-1.23/netio.c.gz
/usr/share/doc/netio-1.23/netio.doc.gz
/usr/share/doc/netio-1.23/netio.gz
/usr/share/doc/netio-1.23/netio.o.gz
/usr/share/doc/netio-1.23/os2-i386.exe.gz
/usr/share/doc/netio-1.23/win32-i386.exe.gz

looks like that this ebuild installs the while 'work' as docs. :-/


Reproducible: Always
Steps to Reproduce:
1. emerge netio
2. look what's installed
3. see that trash in 'doc'
Comment 1 Aaron Walker (RETIRED) gentoo-dev 2005-01-28 02:48:00 UTC
From netio license:

<snip>
This program/these programs can be used freely for private or
educational purposes. If you want to use them for commercial purposes,
please contact the author. You may redistribute this software only if
all files from my original distribution are included unchanged. You may
only add readable documentation files, such as a BBS signature, and only
if they are marked prominently as additions. If you want to include any
part of the orignal distribution with other software, please contact the
author before.
</snip>

Note the part that says we may redistribute this software only if *all files*
from the original distribution are included.

The only files that I can leave out, are files generated by running 'make',
since technically they're not included with the distribution, so I've modified
it to not install the object files (*.o).  I've also added some einfo's to
pkg_postinst so that users understand why those files are being installed.
Comment 2 Stefan Briesenick (RETIRED) gentoo-dev 2005-01-28 12:00:45 UTC
eh, wait!

the license says "You may redistribute this software only if
all files from my original distribution are included unchanged."

And we do this! You don't change the ZIP. You download the original sources w/o any modifications, unpack it and copy some of file onto your computer. The unpacked files are not distributed. 

This part of the license is meant to prohibit changes to the ZIP and its contents. It doesn't say, that you have to *install* all that stuff.

So you just misinterpret the license text.